Jump to content

Archived

This topic is now archived and is closed to further replies.

egis.d

RDP not working after installing File Security

Recommended Posts

Hi,

I installed ESET File Security on Win2k3 server and now have problems connecting to server using RDP. Everything is okay when connecting from LAN but not from external IP. I'm sure Eset is blocking connections 'cause after uninstalling it, remote desktop connection started working again. Unfortunately, I didn't find any of the options to allow remote connections in Eset. Even turning off real time protection and all other security options, AV do not allow to connect to server remotely. 

 

Thanks.

Share this post


Link to post
Share on other sites

Hello,

 

I am not sure File security protects on the network level, or blocks connections; however, a good question to ask is, have you enabled protocol filtering in the advanced setup?

Share this post


Link to post
Share on other sites

File security doesn't have builtin firewall..

Protocol filtering was disabled by default. Tried to enable, then disable again but this did not help.

Share this post


Link to post
Share on other sites

Did you check the server was listening and allowing ports for rdp after the install ?

Are you using port 3389 ?

So your port forwarding on your router from outside your dmz is not working after installing file security ?

hmmm

Share this post


Link to post
Share on other sites

Yes, it was listening to 3389 port and port forwarding is working after installing file security because it starts loading, "Configuring remote session" message appears (Mikrotik router shows moving packets) and then after few moments i get an error: "Remote desktop can't connect to the remote computer...". It feels that File Security just denies incoming connections.

Share this post


Link to post
Share on other sites

Well son of a submariner

 

Sorry for your troubles egis.d

 

Do this.

 

Step 1. hxxp://technet.microsoft.com/en-us/library/cc736451%28v=ws.10%29.aspx

and also for good measure maybe even just turn it off for troubleshooting purposes only.

 

Step 2.

  1. Open ESET File Security by clicking Start > All Programs > ESET > ESET File Security > ESET File Security.
     
  2. Press F5 to open Setup.
     
  3. Expand Computer protection > Antivirus and antispyware > Protocol filtering.
     
  4. Uncheck the check boxes next to Enable application protocol content filtering and Start application protocol protection automatically, if they are checked.

Step 3, Test again if RDP is being blocked.

 

My theory is you may have protocol filtering enabled ? and that could be a cause since its filtering tcp udp traffic.

 

Let us know if this helps post installation of file security.

Share this post


Link to post
Share on other sites

ESET File Security doesn't intervene with network communication except filtering HTTP(S), POP3(S) and IMAP(S) protocols when the feature is deliberately enabled (it's disabled in EFSW by default). You can try renaming C:\Windows\System32\drivers\eamonm.sys and C:\Windows\System32\drivers\ehdrv.sys in safe mode, one at a time, to see if it makes a difference and to rule out real-time protection and HIPS being the culprit.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...