Jump to content

ODBC error installing ERA version 6


Recommended Posts

HI,

 

I am having ODBC connection error when trying to install ERA version 6 on my win server 2003, 32x, domaine controller.

 

- Unable to connect to the database ( error 0) - selected database driver is not correct.

 

If I change to another ODBC driver:

 

- Unable to connect to the database ( error 65535) - PLease check all connection information and check if selected ODBC driver is installed correctly.

 

 

Can you please poste the solution for this,

 

Regards,

 

M.H

 

 

Link to post
Share on other sites

Hello hmatthews,

 

If you encounter this error, you will need to ensure your existing SQL instance is listening on port 1433. To enable the instance to listen on port 1433, please use the following steps:

  1. On the Start menu, point to All Programs, point to Microsoft SQL Server, point to Configuration Tools, and then click SQL Server Configuration Manager.
  2. Navigate to SQL Server Network Configuration -> Protocols for %YOUR_INSTANCE_NAME% (the default is MSSQLServer or SQLEXPRESS)
  3. Double-click the TCP/IP protocol
  4. Locate the Enabled field and change the drop-down box to Yes
  5. Select the IP Addresses tab
  6. Navigate to the IPAll section
  7. In the IPAll section, delete any information in the field "TCP Dynamic Ports"
  8. In the IPAll section, change the field for TCP Port to 1433
  9. Click OK
  10. Select the SQL Server Services entry in the list on the left
  11. In the pane on the right, right-click SQL Server (%YOUR_INSTANCE_NAME%) and select Restart

 

Thank you,
ChadH

Link to post
Share on other sites
  • 4 weeks later...

Hello hmatthews,

 

If you encounter this error, you will need to ensure your existing SQL instance is listening on port 1433. To enable the instance to listen on port 1433, please use the following steps:

  1. On the Start menu, point to All Programs, point to Microsoft SQL Server, point to Configuration Tools, and then click SQL Server Configuration Manager.
  2. Navigate to SQL Server Network Configuration -> Protocols for %YOUR_INSTANCE_NAME% (the default is MSSQLServer or SQLEXPRESS)
  3. Double-click the TCP/IP protocol
  4. Locate the Enabled field and change the drop-down box to Yes
  5. Select the IP Addresses tab
  6. Navigate to the IPAll section
  7. In the IPAll section, delete any information in the field "TCP Dynamic Ports"
  8. In the IPAll section, change the field for TCP Port to 1433
  9. Click OK
  10. Select the SQL Server Services entry in the list on the left
  11. In the pane on the right, right-click SQL Server (%YOUR_INSTANCE_NAME%) and select Restart

 

Thank you,

ChadH

 

I've tried this solution but did not work for me.  Is there something else I can try?  I'm running Server 2012 R2.

Link to post
Share on other sites
  • 1 month later...

I have MS Windows Server 2003 for SBS, Service Pack 2, fully up to date.
 
It uses a Domain Controller
 
I have installed SQLServer2005_SSMSEE.msi
 
I can’t locate where to open Port 1433
 
Assistance would be appreciated please.

post-6622-0-92814600-1425512820_thumb.jpg

Link to post
Share on other sites

Thanks Jim, so given that I am stopped at the next screen with the attached error, what driver or software do I need to have installed to complete the installation?  It seemed to be missing SQL, so I installed SQL2005, and still receive the same error.  The solution to others was to change/open port 1433, so I was thinking that I was in the same boat...
 
Cheers :D

post-6622-0-69123000-1425513714_thumb.jpg

Edited by Blackspear
Link to post
Share on other sites

Again, you can't use SQL 2005, it must be 2008 or later. I think you can install SQL 2008 R2 Express onto your SBS box.

 

You won't need to open 1433 as everythign will be on the same box (I assume?), but if you're installing 2008R2 as a separate SQL instance then you'll need to specify that in the connection properties.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...