Jump to content

Archived

This topic is now archived and is closed to further replies.

soundman87

Remote Administrator Install ODBC Error

Recommended Posts

I am in the process of trying to install the remote administor on my domain controller.  I only have one server and setting up a second server is not an option.  I am already running SQL Server 2012 Express on Server 2008 R2.  So I have setup a second instance for the ERA.  But when I go to install the remote administrator I get and connection error.

 

"Unable to connect to the databases (error 65535) - please check all connection information and check if selected ODBC driver is installed correctly"

 

Is there something that I am doing wrong or more that I need to do?

post-5987-0-58960500-1418831555_thumb.jpg

Share this post


Link to post
Share on other sites

Hello soundman87, please check that the database era_db can indeed be accessed on port 1433.

More importantly, check whether you have the selected ODBC driver installed on your system. The driver is not distributed with our product, you need to install it separately.

Share this post


Link to post
Share on other sites

Hi,

 

I am having the same isuues, trying to install ERA v6 on my win 2003 server 32bit. ODBC driver all well installed.

 

Can someone please post the fix for this error?.

 

Thanks,

 

M.H.

Share this post


Link to post
Share on other sites

Hello

 

I got the same issue. I can connect with ODBC Data Source Administrator but the ESET installer cannot whatever setting I use...

Share this post


Link to post
Share on other sites

Thank you for your help.  In troubleshooting the problem I also tried installing SQL Express 2008 on a test machine and was getting the same results.  After much research on the internet and following SQL troubleshoot guides, I found the solution to my problem.  The server was infact not listening on port 1433 (the port number was blank).  I just did not know were to go to look.

 

The setting I needed was in SQL Server Configuration Manager - SQL Server Network Configuration - Protocals for XXXX (the sql instance name) -  Right Click TCP/IP - Properties - IP Addresses Tab - IPALL - TCP Port

post-5987-0-71780800-1419716547_thumb.jpg

Share this post


Link to post
Share on other sites

Hello soundman87,
 
Thank you for posting this answer. I have reformatted and expanded the steps you outlined.If you encounter this error, you will need to ensure your existing SQL instance is listening on port 1433. To enable the instance to listen on port 1433, please use the following steps:

  1. On the Start menu, point to All Programs, point to Microsoft SQL Server, point to Configuration Tools, and then click SQL Server Configuration Manager.
  2. Navigate to SQL Server Network Configuration -> Protocols for %YOUR_INSTANCE_NAME% (the default is MSSQLServer or SQLEXPRESS)
  3. Double-click the TCP/IP protocol
  4. Locate the Enabled field and change the drop-down box to Yes
  5. Select the IP Addresses tab
  6. Navigate to the IPAll section
  7. In the IPAll section, delete any information in the field "TCP Dynamic Ports"
  8. In the IPAll section, change the field for TCP Port to 1433
  9. Click OK
  10. Select the SQL Server Services entry in the list on the left
  11. In the pane on the right, right-click SQL Server (%YOUR_INSTANCE_NAME%) and select Restart

 

Thank you,
ChadH

Share this post


Link to post
Share on other sites

Is anyone then (following fixing the odd requirement to specify the listening port above) receiving the following error:

 

"The specified database was not used for this purpose before or it is corrupted."

 

Well, yes, it's never been used before. Installing on an existing SQL Server Express instance, but ERA has not yet been installed.

Share this post


Link to post
Share on other sites

Hello Ted,

 

Please ensure there is no database in your existing SQL instance with the name “era_db” (without the quotes). The Remote Administrator installation process will automatically create a new database.

 

Thank you,
ChadH

Share this post


Link to post
Share on other sites

Hello soundman87, please check that the database era_db can indeed be accessed on port 1433.

More importantly, check whether you have the selected ODBC driver installed on your system. The driver is not distributed with our product, you need to install it separately.

Can you explain what you mean by "The driver is not distributed with our product, you need to install it separately."?

 

Thanks,

Share this post


Link to post
Share on other sites

I get the Error 65535 to and it does not make a database.

how can i fix that?

Share this post


Link to post
Share on other sites
Hello,

 

please verify following:

1) in SQL Server Configuration Manager, make sure TCP/IP is enabled and that TCP Port is 1433 (that you are entering during installation) - as you can see on this screenshot.

 

2) make sure, that you have one of the supported ODBC connector installed: SQL Server/SQL Server Native Client 10.0/ODBC Driver 11 for SQL

During installation choose SQL Server, so open ODBC Data Sources, choose Drivers tab and check, whether driver named SQL Server is correctly installed.

 

3) make sure you are using correct login name and password

 

4) to be sure, that you use correct login details, check the connection this way:

- open ODBC Data Sources - create new System DSN and enter the same values as during installation of ERA. In case the test connection fails, they are entering incorrect parameters.

 

P.R.

Share this post


Link to post
Share on other sites

I too am having the same problem. I went to install SQL 2008 R2 express manually (because it kept failing when i tried to install it automatically). I set it up using the default instance. The i manually created a database era_db. Now when i go to install the server i get the error saying this database has not been used for this purpose or its corrupted. HOW DO I INSTALL THIS PRODUCT. This is a nightmare i cannot believe it is this cumbersome to install an antivirus solution. I have verified that the required port is open (it can connect as it knows this database has not been used for this purpose.

 

Please post a workaround as i see many users of this product are having the exact same issue.

Share this post


Link to post
Share on other sites

I had all of these errors but have now completed the installation.

 

I installed a copy of SQL Server 2014 Express first

 

in configuration change the TCP/IP Listening port to 1433 (as above)

 

in the setup when asked for the SQL details I left everything as the default EXCEPT:

database name: change to anything else

admin username/ pass whatever you set in the sql setup

 

This got me around all of the errors mentioned above

Share this post


Link to post
Share on other sites

I was able to get around this issue as well.

 

Here is what I did,

1. installed SQL Express manually

   a. Installed using a named instance; not default

   b. named it ESET

2. Set it to mixed authentication (where you can login with windows authentication or as sa

   a. manually set the sa password.

3. Proceeded with the install as normal

4. opened SQL configuration utility and enabled port 1433

5. Ran the ESET all in one installer

   a. unchecked SQL Express option

   b. unchecked proxy option

Share this post


Link to post
Share on other sites

First I tried to install SQL express using the ERA installer but it kept failing, presumably because I already had an SQL 2008 install on the server. I had to install a separate SQL instance manually, I used the SQL 2014 installer which was extracted during my attempt at an automated install.

 

I needed to set it up with mixed authentication as using just windows authentication failed when I later tried to run the ERA installer minus the SQL server install (I had used windows auth in the drop down but still failed until I used the sa login). Kept getting the ODBC error but I tested the connection in the ODBC manager and it worked fine.

 

Once I had installed my instance I had to go to the SQL server config manager to add the 1433 port, I also had to enable TCP/IP and I also enabled Named Pipes to match the screenshot from soundman87. On the TCP/IP -> IP Addresses tab I also had to enable the section for localhost (contains 127.0.0.1).

 

Now it seems like ERA is installing correctly, taken me most of the day though... Hope this extra info helps some others save time :)

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...