Jump to content

ESET Banking Protection works only on Chrome

Go to solution Solved by Marcos,

Recommended Posts


For some weird reason ESET Banking Protection only works in Chrome now. I mostly use Firefox to browse the internet (it's my default browser) and I have found this month, maybe it's from July that ESET Banking Protection works only in Chrome. If I use the secure all browsers it works in every browser, but I don't want to have it enabled all the time. Right now versions of each browser are: Chrome 116.0.5845.97Firefox 116.0.3, Edge 115.0.1901.203. I disabled protection, did a restart, enabled it again to no avail.

Up until now all these years it worked flawlessly. I haven't made any change to my ESET Internet Security program, I just installed the new version which is Here's a screenshot from my banking protection settings:


Is there anything wrong with the new version?

Link to comment
Share on other sites

Secure Banking redirection wasn't working for a while now. Even last night I was making fairly large purchase using PayPal and it used to redirect automatically to secure browsing, now you need to either  manually copy paste the link or use " secure all browsers" which is pain in the rear.

If I'm not mistaking, year or so ago somewhere in this forum, one of  ESET rep mentioned  that they were thinking of removing the automating redirection and just use "secure all browsers' If this is the slowly tricky implementation now 🤐



Edited by URBAN0
Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...