Jump to content

WSL dir exclusion has broken NOD32 into unfixable state


Ian_H
Go to solution Solved by Marcos,

Recommended Posts

Hi all..

While looking at performance issues, I added a WSL path to my exclusions list; eg:
 

\\wsl$\Debian\home\me

 

This broke NOD32 while trying to save / exit from the configuration dialog. However, it's also completely broken NOD32. I can't load it, I can't uninstall it, I can't do anything with it.

The application doesn't start now on system start (2 processes are present 'ESET forwarder' and 'ESET service'.. trying to kill the forwarder appears to do nothing (does it instantly respawn?), trying to kill the service throws an access denied error.. both of which would seem reasonable for self-protection methods).. however, somehow, I need to removbe this entry from the configuration / start again.

Anyone any ideas on:

- Finding / manually editing a configuration file (assuming it's not encrypted, or a proprietary binary format)
- Resetting the application without having to start it
- Uninstalling it so I can start afresh and export the good config from my laptop

Any suggestions / help on this would be greatly appreciated 😃

 

 

Cheers..

 

  Ian

Link to comment
Share on other sites

  • Administrators
  • Solution

I assume that after 30s the attempt to start ekrn should time out and you should be able to uninstall ESET and after a reboot install it from scratch with default settings.

Link to comment
Share on other sites

Thanks Marcos :)

When I attempted to 'modify' the installation before ('uninstall' not available within add / remove apps), the wizard dialog froze up originally. After a couple of reboots, it allowed me to export the configuration XML file, which I could then edit manually and remove the offending exclusion item entry.. uninstall, reinstall, import config and back up and running.

All sorted now 👍🏻

 

Cheers..

Ian

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...