Jump to content

Archived

This topic is now archived and is closed to further replies.

forkys

Smart Security 8 useless: error connecting to Wifi Home Network

Recommended Posts

After upgrading to ESET v8,  I cannot connect to my Wifi Home Network any more.

Under 'Network Sharing Center' it shows an Unidentied Network as Active Network whereas it should show 'Home network'. No way to make this go away.

 

The  ESET log shows:

Packet blocked by active defense (IDS) 192.168.x.A 192.168.x.B ARP
 (A being my router, and B being my machines IP.)
The firewall logs keeps scrolling and scrolling and being flooded with this and I believe it is the source of the problem.

 

After uninstalling version 8 and reinstalling version v7 everything is OK.

 

Therefore my conclusion: Smart Security 8 contains a serious bug.

 

Running Windows 7 Ultimate, 64bits  

Share this post


Link to post
Share on other sites

Please post the information about installed modules from the About window.

Share this post


Link to post
Share on other sites

Also, if chance or time permits, reinstall or after installing/upgrading to version 8; try flushing your dns cache, disable your network adapter, then re-enable it, followed by a cmd : "ipconfig /renew".

You may get a new prompt by ESS for your subnet to be marked as public or private.

 

Additionally i would be interested to know if after the upgrade and unable to communicate with your router, if going into the advanced properties and deleting and/or re-adding your subnet to the trusted zone solves the issue.

 

Lastly, what model of router are you using ?

:)

Share this post


Link to post
Share on other sites

Thanks. As a matter of fact the actions you suggested are those which I actually have taken before deciding to downgrade to v7- Actions which obviously didn't bring any result. I forgot to mention that through trial & error , i found out that disabling the 'Epfw NDIS light weight Filter' under Wireless Network Properties actually resolved the version 8 malfunctioning. Epfw NDIS driver the culprit of version 8?

Yet I decided this driver to be crucial for sound protection, hence the downgrade to v7.

I have an ASUS RT-N56U router. I fail to see how the router could all of a sudden (unchanged Router configuration/settings) conflict with ESET smart security. It must have been caused by version 8- see also my comment on the Eset log actions.

Share this post


Link to post
Share on other sites

Installed modules: just the default ones that come with the installation of v7 or 8 , excluding Anti Theft which I don't wish  and I do not need the gamer mode to be active /enabled.

 

All very standard , same modules as v7

Share this post


Link to post
Share on other sites

Not sure about the relevance of the "installed modules"- it's everything that comes automatically when downloading and installing the latest version 8. I'm assuming that an ESET moderator would know the content....

 

Currently running v7 for the obvious and stated reasons. You would appreciate that I'm reluctant to uninstall v7 and reinstall v8 just to be able to replicate the v8 "About" information.

 

The culprit in v8 is the activated Epfw NDIS light weight Filter whereas it isn't in v7.

Share this post


Link to post
Share on other sites

I have the same issue, and the only way to fix it when I disabling the firewall, botnet and ids protection. Could be new information that the problem existed on version 7 and the upgrade (v8) still have the issue. Do someone know a fix to this?

Share this post


Link to post
Share on other sites

To troubleshoot issues with blocked communications, please carry on as follows:

- enable logging of blocked connections in the IDS setup

- enable logging to pcap in the IDS setup

- clear your firewall log

- restart your computer

- reproduce the issue

 

When done, disable logging and post your firewall log records here.

Share this post


Link to post
Share on other sites

Can't able to work without internet so please investigate the firewall issue.

Share this post


Link to post
Share on other sites

Not sure about the relevance of the "installed modules"- it's everything that comes automatically when downloading and installing the latest version 8.

 

Just to make sure you understand it correctly: When downloading ESS v8 e.g. it already includes the modules - yes -, but after this modules are constantly delivered through the VSD updates.

So they change gradually and maybe an issue only happens with a specific version of a module.

Share this post


Link to post
Share on other sites

Same problem here, so here is my modul list:

 

Vírusdefiníciós adatbázis: 10873 (20141213) (VSD)
Gyors válasz modul: 5211 (20141213) (quick answer)
Frissítési modul: 1055 (20141118) (update)
Vírus- és kémprogramkereső modul: 1446 (20141208) (virus and spyware)
Kiterjesztett heurisztikai modul: 1153 (20140915) (heuristic)
Kitömörítő modul: 1215 (20141106) (extract)
Megtisztító modul: 1102 (20141112) (cleaning)
Anti-Stealth támogatási modul: 1067 (20141210) (Anti-Stealth)
Személyi tűzfal modul: 1254 (20141201) (personal firewall)
Levélszemétszűrő modul: 1029 (20141103) (spam)
ESET SysInspector modul: 1245 (20141028) (sysinspector)
Valós idejű fájlrendszervédelem modul: 1009 (20130301) (real time filesystem protect)
Fordítástámogatási modul: 1273 (20141008) (translate)
Behatolásmegelőző rendszer támogatási modul: 1155 (20141127) (hips)
Internetes védelmi modul: 1165B (20141128) (internet protect)
Webtartalom-szűrési modul: 1036 (20140625) (webcontent)
Levélszemétszűrő modul: 1989 (20141212) (spam)
Adatbázis modul: 1061 (20141124) (database)

Share this post


Link to post
Share on other sites

I would suggest you to also follow Marcos instructions and PM him with the result.

Share this post


Link to post
Share on other sites

Apparently there are more users having the same problem. I'd say ESET does (or should have) by now a pretty clear picture of the problem, it's cause, yet you are asking us to replicate the error again?

 

That's running around the issue which, circles around creating the dedicated safe HomeNetwork definition setting (when asked after installation) which is not kept by the software, hence the false positives-

 

/please see the below Log I sent before:

 

The  ESET log shows:

Packet blocked by active defense (IDS) 192.168.x.A 192.168.x.B ARP
 (A being my router, and B being my machines IP.)
The firewall logs keeps scrolling and scrolling and being flooded with this and I believe it is the source of the problem.

Share this post


Link to post
Share on other sites

I would be checking to see if your running under public or private and also take note of your subnet and see if ESET added it to the list of trusted zones.

Also verify if the network adapter is using the filter or not.

Share this post


Link to post
Share on other sites

My Trusted zone under personal firewall looks like this:

 

IP: 127.0.0.1; IPv6::1

 

Basically automated configuration during setup v7

 

Is this how it should be? Anyway it doesn't give any problems 

Share this post


Link to post
Share on other sites

If I switch my network from public to private the problem is gone, so it's only happening under public. My settings for home network was always public(without problem) because that is safer, but now I can't able to work under public because of this connection issue.

Share this post


Link to post
Share on other sites

My network settings are always Private/Home, for every ESET version I've used so far.

Share this post


Link to post
Share on other sites

@esetreg: I didn't receive any pm with logs from you, please re-send.

 

@forkys: Please install v8 and carry on as follows:

 

- enable logging of blocked connections in the IDS setup
- enable logging to pcap in the IDS setup
- clear your firewall log
- restart your computer
- reproduce the issue

- pm me the pcapng file created in "C:\ProgramData\ESET\ESET Smart Security\Diagnostics" folder as well as the output of running ESET Log Collector (hxxp://kb.eset.com/esetkb/index?page=content&id=SOLN3466)

 

To fix the issue, right-click a record with blocked communication in your firewall log and select "Don't block similar events in the future" so that a rule is created for the given communication. Let us know if that helps.

Alternatively you can try excluding your router's IP address from active protection (IDS) in the Zone setup -> Zones -> Addresses excluded from active protection.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...