Jump to content

Web administrator not working after migrating to a new server


Recommended Posts

Hello everyone..

 

I have migrated my installation from an old ser to a vmware server, an it looks like it is working ok. Clients are connected and gets updates from the new server and i can do remote installs without any errors, but one thing is not working...

When i am trying to log in to the webadmin it does not approve of my password... i cant log in. The "normal" console is working ok and i can log in as usual and also with AD users from one spesial group...

 

see attachments..

post-5725-0-84720200-1416257230_thumb.jpg

post-5725-0-73369700-1416257231_thumb.jpg

 

 

Anyone have any idea what i have done wrong... :(

 

Best regards

Tor Vidar Berg 

 

Link to post
Share on other sites
  • 2 weeks later...

I have the password and it is working in the console, it is even set up With domain login so i can log in With anyone who is a member of the selected domain Group.... it is Version 5.2.22.0

 

Tor Vidar Berg

Link to post
Share on other sites

the screen shots are from the new ERA v6.x.

it is Version 5.2.22.0

:wacko::D

 

So who tells the truth?

 

As you can read in the Changelog the newest version is 5.2.22.0 and there is no Beta released yet. (at least I didn't see it and in this business beta section aren't much information about this too...)

So... :ph34r:

 

Where/How do you get it? Or can you prove that you're not using - the unreleased - version 6?

Edited by rugk
Link to post
Share on other sites

Hello..

 

i dont know why i have the domain option, must be because i have added domain groups to ERA

As you se in the attachment the version is 5.2.22...

 

 

But back to the question, why cant i log in on my new instal (web)... O n the console i can log in with both the ERA admin and the users i have added to the AD group that is added in the user administration in ERA, so the only thing not working is the web login...

 

 

Any idea??

 

 

Tor Vidar

post-5725-0-11151200-1417371070_thumb.jpg

Edited by torvidar
Link to post
Share on other sites

Hello,

Can you give us a picture similar to the one i have attached:

 

Create a new user in manager, add the AD group you want to push users into the new ERA user as shown i have added the domains administrators group.

Then attempt to login to the web console again with the new user.

 

Let us know the results.

post-1101-0-68957400-1417509274_thumb.jpg

Edited by Arakasi
Link to post
Share on other sites

Also i notice it says connection error.

 

Where are you trying to login to the web console @ ?

The server with ERA installed ? A client workstation ? Remotely ?

 

Keep in mind that database has a specified port etc, any connections need to have exclusions entered if its outside of the server itself. Port 2225

Link to post
Share on other sites

Hello

 

This i have tried several times, and i cant log in to the web admin no mather what.... With any of the users or AD user i their respective AD Group...

 

Cant log in at al :(

 

as i mentioned erlier,  the console is no problem, i can log inn With everyone that i have added, and every AD user belonging to the AD Groups... it is only the web admin that i cant log in to.... at all ...

 

 

I have tried log in local on the machine With ERA installed and several others in my network..

 

All friewalls are off

 

It looks to me that the problem lies between the web server and ERA (same machine) ... like the webserver cant authenticate against ERA...

 

 

Tor Vidar

...

post-5725-0-66678000-1417510432_thumb.jpg

Edited by torvidar
Link to post
Share on other sites

Did you have IIS or SQL, MySql, Access, etc installed prior to ERA installation ?

Did you change the specified port for the web console during initial setup maybe ?

Do you have the port listed in the Server options under other settings correctly?

 

What about potential dns issue, have you tried using the IP instead ?

https://192.168.1.2/ instead of https://SERVERNAME/

 

Although you said all firewalls are off, can you create an exclusion in windows firewall anyway.

Do you have any traffic control from switches or routers ? Web filter policies ? Have you tried with a different browser ? Have you tried launching from inside the ERA console ?

 

Next thing to look at would be logs and/or directories.

Edited by Arakasi
Link to post
Share on other sites

Hello

 

Firewall is as i said off and controlled om klient computers by GPOs so i cant change that. the ERA server is on the same network segment (same ip range) as the client that iam using. i have tried using ip instead of name, still the same

There is only one standard switch between me and the ERA, so nothing is blocking the traffic. i also tried localy on the ERA server, but still the same...

 

Tor Vidar 

post-5725-0-49253200-1417676587_thumb.jpg

post-5725-0-85529900-1417676609_thumb.jpg

Link to post
Share on other sites

Hello again,

 

A few things to point out. Your picture includes the web servers list.

You cannot simply add the http(port 80) and expect it to work.

Try opening the Configuration Editor in ERA, and expand to the Dashboard section to see if all the settings are there correctly, even check that the keys for https are there.

 

My main concern might be that you should uninstall ERA console and server and reinstall, and make sure the db is created and all the settings are correct on the next go around.

Don't forget to export current settings or policies.

Link to post
Share on other sites

In addition, a few clarifications if you will . . .

 

You said "migrated" your installation from one server to a vmware server. What process did you take when you say migrate ? Are you referring to exporting settings and re-importing after you installed on the new server?

Is this a version of esxi ? Do you have multiple servers on one box ?

Is your ERA console now on the new vmware server, and your web console is located on a web server, totally different server?

I think you may need the server that has the console install, be the same server that you go to for accessing the https web console and database.

You might have less issues logging into the web console,

Link to post
Share on other sites

Hello again...

 

I did the migration folowing instruksjons in th KB from hxxp://kb.eset.com/esetkb/index?page=content&id=SOLN2683

And every thing is working ok exept the web admin...

 

everything is installed on one machine, webserver,datrabase, and console, as i can reach from my laptop....ERA is installed on a windows server 2012 R2 according to the recomended spec

 

the hxxp:// in the list is only me trying desperatly :) it is the https:// link i have testing and cant log in

 

Both the old and the new is on the same esxi version 5.5 and the old was a windows xp, that was converted from at phsyical machine erlier this year and has been running since, without trouble

still have it running and the webadmin on that machine it is working ok....

 

 

So as i mentioned earlier i beleve the problem lies between the web server function and ERA. (on the same machine)

 

 

Tor Vidar

Link to post
Share on other sites

How did steps 9-12 go ?

Completed all of them ?

DNS is cleared and reset ?

 

Have you tried querying the db using something other than a web browser?

Can you try connecting to the server with a different program on port 80 ? 443 ? etc

Edited by Arakasi
Link to post
Share on other sites

Hi

Step 9- to 12 went ok, no problem there. All hostnames and ip adresses pointing to the old was changed to the new in policy... dns cleared ipconfig /flushdns and ipconfig registerdns  ...

 

The problem does not lie here, the web portal comes up with the right hostname (the old one is not there anymore) the only error i get is passord/user error when i try to log in...

 

i have not tried querying the database..... i dont know how.

 

hvat other program do you mean.... i have tried several different browsers and there is no different.... same error

 

 

No luck

 

 

 

Tor Vidar

Link to post
Share on other sites

You can try telnet on the specified port to make sure that is good. However as you stated, you probably would not get the web interface if the connection was refused.

First off is it an Access db you set it up on, or sql ?

Access you can use powershell, sql you can use query analyzer.

 

Have a look at my attached pictures and tell me if you can post a shot of yours as well.

 

Location inside the ERA Console: Tools > Server options > Logging tab > Audit log.

Look here for your authentication requests when logging into the web server.

We may be able to determine why.

 

If we have an issue with your administrator password, as Marcos stated way above, the quickest solution would be to contact customer care and reinstall era server and console.

 

However if you would like to keep everything as is, and we have determined its a simple password mismatch, we can help you reset it.

If you want to tackle the repair option and keep everything as is, send me a PM tomorrow during normal business hours for ESET contact : hxxp://www.eset.com/us/about/contact/

Or contact customer care by phone for the direct route.

If i am able to verify the validity of your account, we can provide instructions on a process to clear that admin password, and if its an AD account help pushing that password into it.

Unsure of how the policy goes with the web console passwords, but i would recommend setting the user account password to never expire in AD, if its an admin account thats rarely used locally, but only around the network.

 

Good luck, and sorry for the troubles Tor Vidar

 

 

post-1101-0-74009800-1418104826_thumb.jpg

Link to post
Share on other sites

Hi there..

looked in the audit log and it shows nothing... no failure or sucsess on login from the web administrator. tried to resett the admin password and i can log in to the console without password but no change in the web admin.. it looks like there is no Connection between the console config and the web administrator

 

im am using access db, but im not familiar With using PowerShell,. do you have any examples that i could try?

What should the permissin on the config files look like,,, who should have acess?. now it  is only "system" and "administratos" With full acsess and users With read and execute

 

Tor Vidar

 

 

post-5725-0-54199900-1418112780_thumb.jpg

Edited by torvidar
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...