Jump to content

Java-problem when preparing to migrate from v9 to v19 on Ubuntu 20.04.5 LTS


Erik-NA
 Share

Recommended Posts

Hello

I am preparing to migrate Protect Server onpremise from version 9 to version 10 on Ubuntu 20.04.5 LTS

Have upgraded Java from version 11 to version 17.  eraserver is up and running.

Tomcat9 is a bit tricky. Have created the file "/usr/share/tomcat9/bin/setenv.sh" with the following content:

JAVA_HOME=/usr/lib/jvm/java-17-openjdk-amd64
CATALINA_OPTS=-java.base/java.lang=ALL-UNNAMED -java.base/java.io=ALL-UNNAMED -java.base/java.util=ALL-UNNAMED -java.base/java.util.concurrent=ALL-UNNAMED -java.rmi/sun.rmi.transport=ALL-UNNAMED

Tomcat9 service starts, but after logging in I get the error "Failed to load data: 500 The call failed on the server; see server log for details" in the web interface.

Cannot see anything error-ish in the web server log "/var/log/tomcat9/catalina.2022-12-30.log" or in "/var/log/eset/RemoteAdministrator/Server/trace.log".

Can someone point me where to luck or maybe have a solution?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...