Jump to content

ESET PROTECT Virtual Appliances 10.0.14.0 Hyper-v - Webmin does not start.


microm3nn
 Share

Recommended Posts

Hello
When I try to enable remote access on newly started virtual appliance, webmin don't start. SSH on 22 port work fine. Wen I try to start webmin from ssh this error show up:

[root@era webmin]# ./start
Starting Webmin server in /usr/libexec/webmin
Failed to open SSL key /etc/webmin/miniserv.pem
Failed to create default SSL context at /usr/libexec/webmin/miniserv.pl line 284.

Anyone can check this up and provide some solution?

Link to comment
Share on other sites

  • Administrators

If nobody has an idea, please open a support ticket. I assume it might be a permission issue with /etc/webmin/miniserv.pem or the certificate might be corrupted.

Link to comment
Share on other sites

Support ticket opened.
Temporary workout:
- in /etc/webmin/miniserv.conf change line ssl=1 to ssl=0
- /etc/init.d/webmin restart

Now you can login without https.
If you like you can setup SSL in Webmin -> Webmin Configuration -> SSL Encryption

Edited by microm3nn
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...