Jump to content

Firewall issue with VPN enabled


Recommended Posts

Hi, I'm using Eset Internet Security 16.0.22.0 on Windows 11 22H2. I am using the firewall in intractive mode (it asks me for any new network traffic). I have a standard account (not admin), so I have to enter the Windows administrator password every time I add a new firewall policy. For a long time I have been observing the problem when I am connected to the corporate network via VPN. The corporate network is blocking access to the Internet. I can only use corporate resources during a VPN connection. If a new application tries to connect to the network during VPN connection, very often Eset displays an alert about new traffic (with the possibility of creating a new rule) and when trying to create a rule permanently, the field for entering the administrator password is not displayed. This problem does not occur if I have unlimited access to the Internet. When I work only in the corporate network (without the Internet), there is often no field to enter the password or it shows up with a long delay (2-3 minutes delay). As soon as a new rule is not created, the new application cannot access the network (not even this corporate network). I noticed that restarting the computer helps then, so usually when I use a new application (or the current application has updated) I have to restart my computer several times to create a new rule. I will add that the problem does not occur every time. Sometimes you can create a new rule without any problems. Sometimes I have to restart my computer 2-3 times before Eset "clicks" and the administrator password field appears. Another solution is to indicate that the application can connect to the network until it is disabled (temporary rule) then no administrator password is required so everything works OK. Can you fix Eset so that when Internet access is limited, the firewall in inactive mode always correctly asks for the administrator password (when using a standard Windows account)?

Sorry for my english, i use google translator

Link to comment
Share on other sites

  • Administrators

As for the problem with displaying the password field, do you mean it's not visible in the UAC window when attempting to save the rule?

image.png

Anyways, I'd recommend using automatic mode without custom rules, especially if standard accounts are used.
Also threats can run without connecting to the Internet so interactive firewall mode cannot prevent them, only mitigate possible consequences, e.g. if additional payload is downloaded.

Link to comment
Share on other sites

Maybe the translator translated it wrong. UAC window does not show at all. But it doesn't happen every time. Sometimes it shows up, sometimes it doesn't

 

Other apps don't have this problem, only Eset. And eset only has this problem when there is no Internet

Edited by Tp6ojNfYgWweHa
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...