Jump to content

I'm stuck! Could not delete key on uninstall, could not write value(s) during install. Win7Pro 64-bit

Recommended Posts


My wife recently had her laptop's operating system upgraded from a 32-bit version of Win7 Ultimate to a 64-bit version of WIn7 Professional. The 64-bit OS is the correct one for her computer. The OS is up to date according to Win Update. The new installation came with a trial version of ESET 4 - don't ask why, I don't know. We are existing ESET customers - Smart Security, 2 computer license.


The First Problem:

The ESET 4 did not uninstall cleanly. After searching ESET for the corresponding AV removal tool (there wasn't one and it recommended a normal uninstall) I used ESET 4's native uninstaller using administrator account privileges. Towards the end of the process an error was generated: Could not delete key \Software\ESET\ESET Security. Options were Cancel/Retry/Ignore. After cancelling several times and retrying several times and receiving the same error, I finally chose Ignore and the process completed.


The Second Problem:

OK. now I am trying to install a current version of ESET Smart Security. Using administrator privileges, installation attempts made with both the online installer and the offline installer have failed multiple times. the errors are always at the same spot: Could not write value Installation Status to key \Software\ESET\ESET Security\Current Version\Info. Verify that you have sufficient access or contact your support personnel. Cancel and Retry return me to this same error. If I Ignore, the next quite a few registry values return the Could not write value error.


I am about as comfortable messing with the registry as I am playing catch with a wasp nest.


I have not submitted this to Tech Support yet - thought I would try here first. I am an English speaker living in Vietnam. Last problem I took to Tech was routed through their Vietnam support personnel and our combined language difficulties were quite significant. :wacko:


In the meantime, Avast and Malwarebytes claim that the laptop is free of malware, PUPs or infection. I only installed these after ESET installation failed. They (or any other AV/ malware product) were not on the machine when I was trying to install/uninstall.


My skill level is probably around "Advanced Beginner."


What should I do?


Thank you in advance!



Link to post
Share on other sites

Sorry for the slow reply. Please don't close this topic.


Wife's got a big project going and getting the computer out of her hands is harder than prying barnacles off a rock. <_<


Will update as soon as possible...

Link to post
Share on other sites



Thank You for your patience!


Finally got some time with the computer and here is what happened...


Following the instructions in hxxp://kb.eset.com/esetkb/index?page=content&id=SOLN2289#Win_7. I ran the uninstaller 3 times, rebooting into safe mode after each attempt. None of these attempts showed that there was any antivirus product on the system. (I had previously removed the AVAST)


I then deleted at least part of the ehdrv driver following the instructions in hxxp://kb.eset.com/esetkb/index?page=content&id=SOLN2616. I was able to complete the first step and delete ehdrv.sys from the system32\drivers folder. Then in Step 2,  after selecting "Show hidden devices" there was no ehdrv driver to be found in the Device Manager. There was something called ESET Olmarik/Olmasco Cleaner listed, I left that alone.


I then rebooted yet again and ran the ESET live installer from Admin (from the regular desktop - not Safe mode). The installation failed and gave the following error message: Could not write value Installation Status to key \Software\ESET\ESET Security\Current Version\Info. Verify that you have sufficient access or contact your support personnel. The instalation gave the option to download and run the Specialized Cleaner which I did. The cleaner found no malware.


I went back to safe mode and ran the uninstaller one more time, but it did not find anything.


What is my next step?


Many Thanks!



Link to post
Share on other sites



Downloaded and tried to run ESET Log Collector following the instructions on hxxp://kb.eset.com/esetkb/index?page=content&id=SOLN3466. Immediately got an error: An error occurred during the collection of files. See the log for more info. Tried again with a freshly downloaded copy and got the same results.


I have no idea where to find this log. It is not on the Desktop and it is not in C:\.


(edit for clarity - 10-16-14 1038 ICT)

Edited by blankslate
Link to post
Share on other sites
  • Administrators

The error message mentioned reads "See the log for more info". Did you find more information in the log as to why it failed? If so, could you post the content of the log here?

Link to post
Share on other sites

In the app itself there is an "operation log" that says the following every time I try: (see image)


[11:29:23:246] Removing temp files


[11:29:23:246] ====================================

[11:29:23:246] An error occurred during the collection of files. See the log for more info.


I have looked and looked and can not find any other ESET log. It is not in C:\ or any other place in the file system that I have searched. Perhaps you know its name and default location?






Link to post
Share on other sites
  • ESET Insiders

I think you must to do this recomandations again



Also please create log



Send link to it to Marcos or me in PM.


Thank you.

Link to post
Share on other sites

I found the problem! (and it is a stupid problem - but that is usually how it goes, isn't it?)


I was using eset_av_remover.exe instead of ESETUninstaller.exe


I ran through the whole process again and was able to successfully install and activate a current version of SmartSecurity.


The birds are singing, the sun is shining and all is right with the world.


Thank you so much @Marcos (and @zloyDi) for your kind patience and assistance!



Link to post
Share on other sites
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...