Jump to content

Make a locked option editable


LesRMed
 Share

Recommended Posts

I know it's there, but I'm just overlooking it. Where in the policy can I make these "locked" options editable?

image.thumb.png.cb87262b6d94218bbf13336a5c4f932e.png

Link to comment
Share on other sites

Posted (edited)

I did that, and applied the policy, but they're still showing locked.

image.png.5cdbcc365e689ce1e5c90c1f919db83d.png

 

image.png.fa0f579c1472a6c58c97e912f137dae5.png

In particular, I'm trying to make the exclusions editable (for admins), but Add is grayed out.

image.png.410fd593999b0c77fa9d005836b5e8a8.png

Edited by LesRMed
Add image
Link to comment
Share on other sites

  • Administrators

I've tested it with real-time protection; after activating override mode the padlock symbol disappeared and I was able to pause real-time protection then:

image.png

As for detection exclusions, make sure to enable this setting in a policy first:

image.png

Link to comment
Share on other sites

  • Administrators
3 hours ago, LesRMed said:

Well it doesn't work on my end. You can see my settings. What else can I check?

Are you positive that you have this setting in a policy enabled? It's not in your screenshots above.

image.png

This should make the Add button in Detection exclusions available on clients.

Link to comment
Share on other sites

  • ESET Staff
Posted (edited)

Hello @LesRMed

The behavior with regards to policies is like this: 

  • when a setting is "set by policy" (by set means, the blue dot / red flash are shown) the setting is NOT editable on the client.  If setting is not "set by policy" if the user locally has admin rights / knows the password to settings, he can change the local configuration freely. 
  • only way how to temporarily override the policy settings which are set by ESET PROTECT is by enabling the override mode. Override mode set to "on" and set by policy. On your screenshot, the override mode is neither enabled, neither configured to be reflecting the policy settings. However, once the override mode ends, the settings will revert to the previous state. 
  • In order to allow "local exclusions", you need to follow the recommendation from Marcos above. If you allow them being "appended", endpoint will take into consideration exclusions set centrally, and also the ones that are set locally. 
Edited by MichalJ
Link to comment
Share on other sites

  • ESET Staff
Posted (edited)

Hello @LesRMed

I have opened this up with our QA department and this is what they came up with: 

In case you enable the setting that allows appending the globally set exclusions to the local list, it will enable you to add the local ones. However, what you need to do first on the endpoint side, is to adjust the "combo box" to "show local exclusions". Once this is done, the add button will enable, and allow you to enter the exclusion locally. 

I have filed an improvement request, to change this behavior, as it is considered as not intuitive. 

set local list.png

show local rules.png3 - edit exclusion.png

 

Edited by MichalJ
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...