Jump to content

Eset web console vs Apache Tomcat v.10


root
 Share

Recommended Posts

Is it incompatible? We were trying to run webconsole with newest Apache but no result. With Apache 9xxx I works fine

thanks for opinions and tips

Link to comment
Share on other sites

Thank you now all is clear

BTW. In this link there is also mentioned regarding to Java, that supported version is JDK 17. We use JDK 18 and all is working fine. Would you advise to downgrade to 17 or keep using 18 ?

thank you in advance 

Link to comment
Share on other sites

Hi guys! It is a good question! I have the same issue. I have ubuntu server and tomcat 9.31, but Eset Protect indicate that it is not a good version... but this is the latest version that supported ubunty server... Another story with Java... I installed 17, but the system indicate 11....

Outdated Server Components
Third-party components used by the ESET PROTECT Server are outdated and should be updated as soon as possible.
Web serverApache Tomcat/9.0.31 (Ubuntu)
Java Runtime Environment (JRE)11.0.16
 
 
Link to comment
Share on other sites

  • ESET Staff

Hi. For now, I would recommend to just stay on versions that do work for you. Indication was added to notify especially of "Windows" users which tend to use old and unmaintained versions of those components. We will probably have to target this in next release and possibly modify communication in a way that it is supposed to recommend specific component versions for the future.

Regarding Java versions, officially only LTS versions are supported, as other versions are very short-living and tend to introduce breaking changes. We do expect that version 17 will be supported by ESET PROTECT for a longer time. But as of now, from technical perspective, console is still compatible with v8 (but this will probably change in near future).

Link to comment
Share on other sites

6 hours ago, lleysan said:

Hi guys! It is a good question! I have the same issue. I have ubuntu server and tomcat 9.31, but Eset Protect indicate that it is not a good version... but this is the latest version that supported ubunty server... Another story with Java... I installed 17, but the system indicate 11....

Outdated Server Components
Third-party components used by the ESET PROTECT Server are outdated and should be updated as soon as possible.
Web serverApache Tomcat/9.0.31 (Ubuntu)
Java Runtime Environment (JRE)11.0.16
 
 

Try to define which Java is used directory  in Apache tomcat  in Java tab.(bin/server.dll)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...