Jump to content

"Remote Host" shows IP of our ESET Protect VA instead of client's IP

Go to solution Solved by kapela86,

Recommended Posts

Some background:

We have 100+ clients, most of them are local LAN/WIFI clients and few are remote clients. We have ESET PROTECT VA and I set it up so clients connect to it using hostname (e.g "esetprotect.ourdomain.com"). On our local DNS servers I setup this hostname to point to LAN IP of our PROTECT VA, and on external DNS servers I pointed that hostname to WAN IP. Recently I made small change so that every client would use a proxy that is by default on PROTECT VA and I used hostname for proxy server. Proxy is only available on LAN IP and It's working fine, local clients use it for updates and when external clients try to connect, they can't and then use direct connection to eset update servers.

And the issue is:

I recently noticed in ESET PROTECT that for some clients the column "Remote Host" shows LAN IP of PROTECT VA instead of real client's LAN IP. This didn't happen when they weren't using proxy. I think it's some kind of bug in PROTECT.


Link to comment
Share on other sites

I notice a similar thing on my web console, when I want to see the IPs of the notebooks connected via VPN to my network, it shows me the private IPs of their devices on their home router (not the private IP that the VPN assign them on my network, or the public IP of their home networks at least).

I really don’t know why this is so.

Edited by RagnarLK7
The word "assing" was incorrect before. I edited that to "assign".
Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...
  • 1 month later...
  • Solution

Solved. The problem was that some computers had old policy settings for Management Agent and some new, but I didn't force all those settings. And to answer @RagnarLK7 question, if you force this to go through proxy then Remote Host will show proxy IP


Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...