Jump to content

Port forwarding for Minecraft server not working


Recommended Posts

Hello! I know this issue has been brought up many times, but I have tried many things and it still shows the port as closed when I check it.

I have tried creating a rule in both ESET and Windows firewall to allow the connection, but that hasn't seemed to work. Attached are screenshots of the rule I have tried to create to allow the port. I left everything in the remote field completely blank.

Any help would be much appreciated. Thank you!

generalrule1.png

localrule1.png

Link to comment
Share on other sites

6 hours ago, Nightowl said:

As per screenshot , you have enabled the port to be open in LAN and not in WAN which is Remote tab if I am not mistaken.

Thank you for the quick response!

I'm in the remote tab, and I don't see any option to change LAN/WAN. I tried switching the port from the local to remote tab and trying that, but that didn't seem to work. Is there a different IP I have to enter? The one for the router? I think the IP for the router is open on the port, but the one for the computer still says it is closed. Do both have to be open in order for people to connect? 

Attached is a screenshot of the remote tab if that helps.

Thanks again!

remoterule1.png

Link to comment
Share on other sites

  • Most Valued Members
8 minutes ago, AlolanZygarde23 said:

Thank you for the quick response!

I'm in the remote tab, and I don't see any option to change LAN/WAN. I tried switching the port from the local to remote tab and trying that, but that didn't seem to work. Is there a different IP I have to enter? The one for the router? I think the IP for the router is open on the port, but the one for the computer still says it is closed. Do both have to be open in order for people to connect? 

Attached is a screenshot of the remote tab if that helps.

Thanks again!

remoterule1.png

Try to put the same port number in both places , Local and Remote

And in Local tab , Put the exe of minecraft server

And for example if you have a router/firewall , you must also configure it for Port Forwarding , it will be blocking connections before ESET.

Link to comment
Share on other sites

24 minutes ago, Nightowl said:

Try to put the same port number in both places , Local and Remote

And in Local tab , Put the exe of minecraft server

And for example if you have a router/firewall , you must also configure it for Port Forwarding , it will be blocking connections before ESET.

I tried putting the port in both tabs; that didn't seem to fix it.

By the exe, do you mean selecting the folder for the server under where it says applications in the local tab? Or something with inputting an IP in one of the fields? I tried both of those and neither worked, but I may have misunderstood your advice.

I also tried opening a port in the windows firewall, for both inbound and outbound, allowing as much as possible for the 25565 port and opened one for the router too.

Link to comment
Share on other sites

  • Most Valued Members
Posted (edited)

Make sure from your router , you portforward to your LAN IP address with the port you specified

Remove the rules from ESET , if the connection is passing to your computer from your router , then you should find ESET blocking the traffic through Network Troubleshooter

Then you could allow the server through Network Troubleshooter because there you can see what is ESET is blocking / has blocked in the recent specified time.

Edited by Nightowl
Link to comment
Share on other sites

2 hours ago, Marcos said:

Does temporarily pausing the ESET firewall actually make a difference?

I just tried it, and it seems that disabling the firewall and then checking the port still shows it as closed.

Link to comment
Share on other sites

  • Most Valued Members
Posted (edited)
6 minutes ago, AlolanZygarde23 said:

I just tried it, and it seems that disabling the firewall and then checking the port still shows it as closed.

That means that your firewall/router is still blocking the connection from passing to your computer.

Check this website : https://portforward.com/softwareguides/minecraft/portforward-minecraft/

And then after you can look for your router model and they will explain with screenshots how to properly portforward.

Once it's done , then you would see the connections coming to your computer and then ESET will be able to catch them.

Edited by Nightowl
Link to comment
Share on other sites

  • Most Valued Members
Posted (edited)
3 hours ago, SeriousHoax said:

You probably need to enable UPnP on your router. 

UPnP can introduce security issues , I'd prefer to have it disabled.

A portforward from the router to the local LAN address of the computer who have the minecraft server and also you need to make sure that the computer doesn't get a new IP from the router's DHCP so the portforward rule will not break.

Edited by Nightowl
Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...