Jump to content

outdated server components


Go to solution Solved by Marcos,

Recommended Posts

hello , after updating to protect 9.1 i keep getting this error : outdated server components : database server Microsoft sql server 2019 RTM express 15.0.2000.5

this is the last express i could find , and i reinstalled it ..and the server is showing this version in the About section .. but i keep getting it .

I rebooted , tried to upgrade server components , even tried to reinstall all ...still have the error 

what should i do ? i dont have another version on the server

Link to comment
Share on other sites

  • Administrators
  • Solution

Please refer to https://help.eset.com/protect_admin/91/en-US/update_third_party_components.html

for information about what components are considered outdated. For SQL Express 2019 users we'll probably add a remark that the latest CU must be installed (https://www.microsoft.com/en-us/download/details.aspx?id=104313).

Link to comment
Share on other sites

1 hour ago, Marcos said:

JAVA 11 LTS is supported until September 2026. I am pretty sure eset-protect 9.1 won't be supported at that time. so please don't mark the component as outdated when its life is longer then the eset product itself. it is very strange.

Link to comment
Share on other sites

I think you need to install the latest Cumulative Update for SQL Server 2019.  The latest is CU16.  The version of SQL Server 2019 that you have is 15.0.2000.5, which according to ESET's article on outdated components, is outdated.  It will warn you that it's outdated if it's lower than 15.0.4223.0.

https://support.microsoft.com/en-us/topic/kb4518398-sql-server-2019-build-versions-782ed548-1cd8-b5c3-a566-8b4f9e20293a

https://help.eset.com/protect_admin/91/en-US/update_third_party_components.html

Edited by T3chGuy007
Link to comment
Share on other sites

  • Administrators
On 7/27/2022 at 5:41 PM, tbsky said:

JAVA 11 LTS is supported until September 2026.

This will be subject to further internal discussion since it's an LTS version.

Link to comment
Share on other sites

On 7/28/2022 at 7:21 PM, Marcos said:

This will be subject to further internal discussion since it's an LTS version.

Could you confirm whether the latest ESET Protect can function properly with JAVA 11? We are getting the Outdated Components message too, and I wanted to be sure that this is recommended, not mandatory upgrade. 

Link to comment
Share on other sites

I'm running ESET PROTECT (Server), Version 9.1 (9.1.1295.0) and ESET PROTECT (Web Console), Version 9.1 (9.1.292.0) with JDK 18.0.2, but I think you need to at least install JDK 17 because ESET PROTECT will report anything lower than JDK 17 as outdated.

https://help.eset.com/protect_admin/91/en-US/update_third_party_components.html

https://www.oracle.com/java/technologies/downloads/#jdk18-windows

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...