Jump to content

Disable clipboard copy and past during a remote desktop session


Recommended Posts

Hi to all,

I need to disable the copy an paste possibility during the remote connection on a client.

this is the scenario: An user is connectect by an RDP session to an another pc. i want to block te possibility to copy and past data between the two pc. The same thigs that is possible using the grup policy on a windows domain.

Is it possible to this with eset configuration?

thank you

Link to comment
Share on other sites

  • Administrators

It's not possible using ESET. You can disable clipboard sharing in the RDP setup:

image.png

On a server you could configure it as follows:

Windows 2016 server:

In Windows 2016, these settings are controlled within Group Policy.

    Launch “msc“.
    Navigate to “Computer Configuration” > “Administrative Templates” > “Windows Components” > “Remote Desktop Services” > “Remote Desktop Session Host“.
    Ensure “Do not allow Clipboard redirection” is set to “Enabled“.

Windows 2012 server:

    Open “Server Manager“.
    Select “Remote Desktop” Services.
    Select “Collections“.
    Select “Tasks“, then choose “Edit Properties“.
    Under the “Client Settings” tab, ensure the “Clipboard” and “Drive” are disabled.

Windows 2008 server:

    Launch “Remote Desktop Session Host Configuration” from the server.
    Under “Connections“, right-click the connection and select “Properties“.
    Select the “Client Settings” tab, and make sure the “Clipboard” box is checked. If you don’t want to allow copying and pasting of files, make sure the Drive selection is checked. Click OK when done.

 

Link to comment
Share on other sites

On 6/9/2022 at 8:34 AM, Marcos said:

It's not possible using ESET. You can disable clipboard sharing in the RDP setup:

image.png

On a server you could configure it as follows:

Windows 2016 server:

In Windows 2016, these settings are controlled within Group Policy.

    Launch “msc“.
    Navigate to “Computer Configuration” > “Administrative Templates” > “Windows Components” > “Remote Desktop Services” > “Remote Desktop Session Host“.
    Ensure “Do not allow Clipboard redirection” is set to “Enabled“.

Windows 2012 server:

    Open “Server Manager“.
    Select “Remote Desktop” Services.
    Select “Collections“.
    Select “Tasks“, then choose “Edit Properties“.
    Under the “Client Settings” tab, ensure the “Clipboard” and “Drive” are disabled.

Windows 2008 server:

    Launch “Remote Desktop Session Host Configuration” from the server.
    Under “Connections“, right-click the connection and select “Properties“.
    Select the “Client Settings” tab, and make sure the “Clipboard” box is checked. If you don’t want to allow copying and pasting of files, make sure the Drive selection is checked. Click OK when done.

 

Hi thank you for your complete answer.

Is there any additional software (Eset or not) to manage these policy in hybrid enviroment where it's not possible to apply the group policy (es. non on domain computers)?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...