Jump to content

Umidigi A5 crashes 1 min after booting after enabling ESET paid features


Recommended Posts

Hi,

I wonder if you test your ESET Mobile product with cheap Chinese phones. Because my Umidigi A5 was left completely unusable after enabling the paid options in ESET Mobile.  And I do know this Mediatek based phone has some irks (eg: Google Play Books crashed with an update delivered by Google around mid-2020, it started crashing in a loop, non-stop, and since Play Books is one of the preloaded apps, there was nothing I could do other than seeing this app crash in a loop. I had to find the Google product manager and email him directly. He told me "well, you seem to have identified a very obscure bug of this particular Mediatek SOC related to the bitmaps rendering"). Two months later they issued an app update that fixed the issue. I never knew what the "obscure Mediatek SOC bug" was.

Back to the ESET topic... Let me explain: I had the ESET Mobile app installed, with the freeware features. The last scan performed was mid-December 2021. This Umidigi A5 had its last software update by March 2021, so I knew it had surely several exploitable holes (those that are not patched by Play Protect).

Only recently I noticed that when I selected an ESET full scan manually, my phone would freeze a few seconds after the scan started. And by freeze I mean, COMPLETE LOCK UP, even the time at the top would freeze. I blamed it surely on the old SD card in there that is 4 years old. "Maybe if I remove the SD card it won't luck up". I thought. -I was wrong, but more on that later-.

Since Play Store informed me this week that it had disabled an app that was "dangerous" (speedcheck.org by Etrality Gmbh) because it can "steal data and control your device" - I got a bit paranoid and decided to pay and enable all the security features. It worked, until the first phone reboot.

Now my phone crashes every single time shortly after the launcher appears. About 30 to 40 seconds after entering my PIN. My smartphone is basically unusable. Luckily I was able to do some things in the first few seconds when the phone works, allowing me to move accounts and 2FA codes to another device. But others, I wasn't so lucky.

I'd like to know if your regular tech support can provide any help in situations like this -I worked at tech support, I know how things work, first they walk you thru all the known "known solutions" flowchart and only after a while your request is escalated to "tier 2"... or if it's better to contact your research labs directly...

I'm not the average user, I'm proficcient with adb.exe, and I'd like to get to the bottom of this, what is causing the crashes and if this was related to the malware that play protect recently disabled (check it out yourselces, https://play.google.com/store/apps/details?id=org.speedspot.speedanalytics is gone from play store) or some kind of incompatibility between the Android 9 in the Umidigi A5 and your software.

Thanks in advance.

Aissac f.

Link to comment
Share on other sites

  • Administrators

Please open a support ticket via the built-in form and let logs to be submitted to ESET for perusal. You may be asked to make a test with a different SD card. Do the issues go away after temporarily uninstalling ESET and return as soon as you reinstall ESET?

Link to comment
Share on other sites

55 minutes ago, Marcos said:

Please open a support ticket via the built-in form and let logs to be submitted to ESET for perusal. You may be asked to make a test with a different SD card. Do the issues go away after temporarily uninstalling ESET and return as soon as you reinstall ESET?

Hi Marcos,

Thanks for the quick reply. My SD card was removed in the end (it was mounted as external storage, fat32, not as internal storage extension).

I can't uninstall ESET because the phone freezes as soon as I confirm the uninstall process. It's very odd.  I can't even try the proposed solution of the knowledge base of going to the app storage settings and erasing it. It locks up before it could tell me it has erased the storage.

https://support.eset.com/en/kb3529-repair-app-data-in-eset-mobile-security-for-android

Whatever I do the phone crashes shortly after booting. Unless I tell it to begin a system scan. Then it crashes about one minute afterwards. If I minimize - switch focus from the app while scanning, I can see the little ESET armor icon at the top of the screen moving... for a few moments (a minute?) then it stops moving and I know the phone has locked completely.

I guess any and all debugging will have to be done via ADB (luckily I have it with developer mode and USB debugging enabled) because one can't even do in-device testing on a phone that freezes up. I even tried going into the Android recovery mode menu and selecting Wipe Cache Partition. The process works. But it doesn't make any difference wrt crashing. It doesn't seem to be a phone-hardware issue because from the recovery menu I can select "self test" and "graphics test" and everything completes normally.

What is really odd is that even with all the UI "FROZEN", sometimes pressing the power button brings the "screenshot, reboot, power down" menu. But you can't tap anywhere.... taps are ignored...

Thanks. Following your suggestion I will open a support ticket.

 

Link to comment
Share on other sites

  • Administrators

Sounds like a severe hw or Android issue. I'd back up all data and perform a factory reset followed by upgrade of Android.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...