Jump to content

Slow installer downloads from locally hosted ESET Protect server


mille535
 Share

Recommended Posts

I just recently migrated my companies ESET Protect server from an old virtual appliance to a Windows based install and everything works great, except downloading custom installer packages. Which takes an average of 13 minutes to download. We are an MSP to we are often creating custom installers for clients so slowness is extremely frustrating. That being said everything else post migration seems to be a lot quicker and more fluid in its operation.

The server is Windows Server 2019 with MySQL 8, ESET Server, ESET Web Console, and ESET File Security installed and is up to date with Microsoft patches.

Has anyone else run into this issue or have any pointers that could help me getting this download speed problem resolved?

esetdlslow.png

Link to comment
Share on other sites

Hey @Peter Randziak,

It's all the time. I think I have figured out it over the weekend. It looks like I didn't have the Apache HTTP Proxy component installed. After installing that component downloads are back up to full speed.

Thanks,

Kirk

Link to comment
Share on other sites

  • ESET Staff
5 hours ago, mille535 said:

Hey @Peter Randziak,

It's all the time. I think I have figured out it over the weekend. It looks like I didn't have the Apache HTTP Proxy component installed. After installing that component downloads are back up to full speed.

Thanks,

Kirk

Unfortunately I do not think this is related - installing HTTP proxy would help with "creation" of the installer itself, which is indicated by progress dialog in the console itself and it involves downloading of installer for ESET repository servers through HTTP proxy, and only in case installers are not cached locally yet.

Once generated installer is ready, download as reported in this issue is performed, and in this case, file is hosted by Apache Tomcat (where PROTECT console is hosted) and downloaded directly by your browser, so it might indicate problem with connectivity between browser and console, or performance degradation of Apache Tomcat. I would recommend to focus on those two aspects in case this issue reoccurs.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...