Jump to content

Cannot Get Quickbooks To Work With Eset


decoratingden
 Share

Recommended Posts

Hello all,

 

New ESET user here. Just made the switch from Symantec. However, now I am experiences issues with Quickbooks that I never had with Symantec. I can open company files but I cannot open them in multi-user mode. I am getting the error H202 "Port is not available". Although I went into the policy in the Administrator Console and added the appropriate TCP rules to allow Quickbooks ports for incoming and outgoing. I am of course saving this...but maybe the client isn't updating? It may sound insane but it is 9:00pm and I've been here on a Saturday since 8:30am to try to figure this out. It needs to be done this weekend and I am desperate...any ideas of what I'm missing here!?

 

Windows Firewall IS disabled on both the Server 2012 R2 and client machines Windows 7 Pro

Edited by decoratingden
Link to comment
Share on other sites

  • Administrators

Do you have ESET Endpoint Security installed? If so, does switching the firewall to learning or interactive mode and creating the appropriate rule help?

Link to comment
Share on other sites

Last time i had to configure my own Quickbooks, which uses multi user as well as a pos system, i had to manually create my rules, the modes did not work from me.

You must turn on "logging of all blocked operations" go to the Tools > Log Files > firewall section and document the incoming IP and any outgoing, and create rules based on what you see.

I think some of my rules had the applications listed, but if i remember correctly, i just used the local IP and port, and nothing else.

Link to comment
Share on other sites

Do you have ESET Endpoint Security installed? If so, does switching the firewall to learning or interactive mode and creating the appropriate rule help?

I have ESET Endpoint Antivirus installed. I tried switching it to learning and interactive from the Policy Manager but that didn't work for me. I ran a telnet and failed for all of the Quickbooks ports BUT connects for basic ports like RDP 3389 and ESET 2222.

 

Last time i had to configure my own Quickbooks, which uses multi user as well as a pos system, i had to manually create my rules, the modes did not work from me.

You must turn on "logging of all blocked operations" go to the Tools > Log Files > firewall section and document the incoming IP and any outgoing, and create rules based on what you see.

I think some of my rules had the applications listed, but if i remember correctly, i just used the local IP and port, and nothing else.

Thanks Arakasi! I'll try that and let you know my results! I appreciate your help.

Link to comment
Share on other sites

Last time i had to configure my own Quickbooks, which uses multi user as well as a pos system, i had to manually create my rules, the modes did not work from me.

You must turn on "logging of all blocked operations" go to the Tools > Log Files > firewall section and document the incoming IP and any outgoing, and create rules based on what you see.

I think some of my rules had the applications listed, but if i remember correctly, i just used the local IP and port, and nothing else.

I went to Tools but did not see Log Files on the server. So from the client I did this but did not see firewall. Here is a screenshot. I am using the Endpoint Antivirus.

 

I did add rules in the Policy Manager to allow TCP ports 8019, 56723, and 55353-55357 both ways. The Quickbooks Data Manager is installed on another VM so I can't manually add files in for exclusion. I have File Security installed on the Quickbooks VM.

post-5000-0-41421400-1408973277_thumb.jpg

Link to comment
Share on other sites

Endpoint antivirus does not include the details we provided. It also does not filter most internal network traffic. It does not have a firewall, only a http scanner for web, on port 80, 8080, 3128. It also has protocol filtering for internal applications, however i dont think it blocks Quickbooks. You could try adding all the quickbook files and updaters to be excluded from protocol filtering, and then report back your findings.

Edited by Arakasi
Link to comment
Share on other sites

Thanks guys for your help. I called ESET support today since they weren't open during the weekend and got this all figured out.

 

For those landing here from Google:

  • Create exceptions to the paths of all Quickbooks installation (Client and server database) under real-time protection. Be sure to include the Program Files (x86) path for 64 bit machines. BE SURE TO DO THIS FOR THE SERVER PACKAGE TOO IF YOU'RE USING FILE SECURITY!
  • Disable network drive scanning
  • Force the clients to update

Also I must of left Windows Firewall open on the Quickbooks VM, so we also disabled that in the mix. I'm sure it contributed to the problem. It was disabled on everything else.

Link to comment
Share on other sites

  • Administrators

Will the problem occur if you remove the exclusions and enable scanning of network drives? I wouldn't recommend disabling that as potential malware run from network shares wouldn't be detected and a virus might infect local files as well.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...