Jump to content

Archived

This topic is now archived and is closed to further replies.

delicategeek

"ask For Permission" Doesn't Work Without An Application

Recommended Posts

I want ESS to ask me for permission, when any application on my system tries to connect to a specified IP address.

 

I create a rule with application="", action="Ask",destination IP ="192.168.1.72".

=>> The connection is always refused, the permission window never shows

 

I create a rule with application="", action="Allow",destination IP ="192.168.1.72".

=>> The connection is allowed, like expected.

 

I create a rule with application="C:\Program Files (x86)\Internet Explorer\iexplore.exe", action="Ask",destination IP ="192.168.1.72".

=>> When I try to access the IP with Internet Explorer, the permission window shows, when using Chrome it doesn't (like expected)

 

What settings do I need in order to ask for permission for *any* application without having to create rules for all internet-enabled applications on my computer?

Share this post


Link to post
Share on other sites

Don't select any application and leave just the remote IP in the rule.

Share this post


Link to post
Share on other sites

Also i have discovered if you're selecting applications, you must choose ie 32-bit and ie-64bit if running on a 64bit OS and the application has both versions.

At the bare minimum you have to do this with IE, hence the reasons its better not to select an app and just use the port alone.

Share this post


Link to post
Share on other sites

Don't select any application and leave just the remote IP in the rule.

That's what I thought, that's what I did, that's what doesn't work and that's the reason I wrote this topic in the first place.

 

If I create a new rule with just rule name, action and destination IP set, only the "Block" and "Allow" actions will work as expected, the "Ask" action will always just block the connection and never show a window asking me for anything.

 

If I add an application the "Ask" action will work like expected, but only for this single application. Without an application set, "Ask" will always just block.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...