Jump to content

ESMC not installing agents


praznovsky
 Share

Recommended Posts

Hello.

 

We are facing issues on one customer with deploying ESMC. We deployed ESMC console as a virtual machine appliance and wanted to install agents from it across the environment, but when we tried the installation it was not successfull the job just timed out. So we wanted to locate the issue, hence we created virtual machine with windows 10 OS, we turned off firewall, proxy and UAC  ( They are running on the same HyperV host and are in identical subnet ). And we still was not able to install agent on via ESMC, it just timed out. After that we tried to install agent manually on the test virtual machine and after manual installation the machine connected without issues to the ESMC. After this we uninstalled the agent from virtual machine and removed the machine  from ESMC and tried the to run installation again and now the job won't even start, before it job at least started and timed out after about 0.5 hour, now it just sits in attempting to start job status for about an hour or two and than aborts due to not being able to start the job.

 

Could you please help us figure out why we are unable to push the agents from ESMC ?

 

 

Link to comment
Share on other sites

  • Administrators

By ESMC you mean ESET PROTECT v9?

As for deploying the agent, preferred methods are via GPO or using the ESET Remote Install tool as per https://help.eset.com/protect_install/90/en-US/?component_installation_agent_windows.html

Available methods

There are various installation and deployment methods available for ESET Management Agent installation on Windows workstations:

Method

Documentation

Description

GUI based installation from the .msi installer

This chapter

KB

The standard installation method.

This method can be executed as server-assisted or offline installation.

Use this method when installing Agent on ESET PROTECT Server machine.

ESET Remote Deployment Tool

Online Help

Recommended for mass-deployment over local network.

Can be used to deploy All-in-one installer (Agent + ESET security product)

All-in-one Agent installer

Create an All-in-one Agent installer

KB

The installer can include also a security product and embedded policy.

The size of the installer is several hundreds of MBs.

Agent live installer

Create a Agent live installer

KB

The installer is an executable script. It has a small size but it needs access to location of .msi installer.

The script can be edited to use local installer and HTTP Proxy.

SCCM and GPO deployment

SCCM

GPO

KB

Advanced method of remote mass-deployment.

Using a small .ini file.

Server task - Agent Deployment

Online Help

KB

An alternative to SCCM and GPO.

It is not viable through HTTP Proxy.

Executed by ESET PROTECT Server from the ESET PROTECT Web Console.

Link to comment
Share on other sites

Thank you for answer but I am aware of options and also I am familiar with link you posted and copied contents of into the post. What I was asking for is help why the remote deployment tool is not working on our customers environment, not even on the test virtual machine described above. 

Link to comment
Share on other sites

  • ESET Staff

Hello, just to check, have you tried to use the "push install" (from the server) or the "remote deployment tool" (the standalone utility, that just pushes the package over local area network). The first option is in general very sensitive for network configuration, and there is a lot of prerequisites for it to work. We in general do not recommend this option, in case other options are available (GPO, SCCM, or other viable alternative). 

Also, ESMC (7.x) has been replaced with ESET PROTECT (8.x / 9.x). It might be possible, that deployment of V7 agents, which are in limited support only no longer works properly. 

https://support.eset.com/en/kb3592-is-my-eset-product-supported-eset-end-of-life-policy-business-products 

But I assume, that is just a mistake in product name. 

Edited by MichalJ
Link to comment
Share on other sites

  • ESET Staff

I would recommend to open support ticket int the meantime as this might require more data for proper analysis, as there are various externalities that might have imact on this functionality.

But in order to triage this issue, I would recommend to perform various experiments that might help locating the problem:

  1. I would recommend to test whether manual installation work on target machine when "Live installer" = BAT-script based installer works on target device, as this is the same script that is supposed to be executed remotely. As it is live installer, it will be downloading package from ESET repository, which might results in timeouts or download errors. Also it might be impacted by HTTP proxy configuration
  2. I would check whether Remote Deployment Tool can actually deploy package to the device. It uses the same remote access mechanisms, so in case Windows = it might indicate that remote machine is not properly configured and is rejecting remote connections required for deployment.

Also please double check our operating system is updated - I am not sure whether such older appliance had actually support for SMBv2 protocol - it is possible that updated Windows 10 machines has no longer support for older protocols and thus rejecting remote connections. Prior to system upgrade (especially in case it was no upgrade for a long time) I would recommend to create virtual machine snapshot so that revert is possible in case of other issues.

In case it won't help to point out the problem, trace.log of ESMC Server service might provide more details, but It seems this might be related to network problems. As deployments are performed sequentially, in case they are no longer starting, it is possible they are stuck in attempts to connect to one of previous devices. Service restart would probably resolve this until next stuck attempt is made...

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...