Jump to content

Ess 7 Firewall Blocked My Xshell Connection With Vmware Bridged Mode


Recommended Posts

VMware Workstation Bridged Networking installed centos with ESET Smart Security 7 Firewall.

When I use Xshell to manage the virtual host, after few minute,it will disconnected.Xshell tips that:

Connection closed by foreign host.

 

I opened eset firewall log,it displays that:

eset tcp packet not belonging to any open connection(from my virtual host ip, target my local host ip)

 

I tried that:

From the Personal Firewall tree on the left, Click IDS and Advanced Options, and then select Allow communication for bridged connections from the Allowed Services tree.

 

But it still not working!

 

And I tried that:

Add rule to allow TCP & UDP connection to my virtual host ip, but it stall not working!

 

when I closed firewall, it work! and when I change my vware virtual host networking switched to NAT mode, ite work!

 

What do I need to do to let firewall to support Bridged Networking with Xshell link?

Link to post
Share on other sites

Have you tried switching the firewall "mode" to something other than automatic ?

Try learning mode then see if it creates the correct rule for you.

Then try Interactive if that doesn't work and wait for prompts to allow.

If that still doesn't work, you are going to have to create a rule manually by specifying application, tcp udp port type or number, as well as local and remote ports or subnet ranges to be allowed or blocked etc.

 

If none of the above work, we are going to need a look at your logs. Post them back here ensuring any public IP's are not listed. Leave the private behind dmz so we can give the correct rule to create.

 

Let us know !

Link to post
Share on other sites
  • Administrators

To find out what communication is blocked, do the following:

- enable logging of blocked connections in the IDS setup

- clear your firewall log

- restart the computer

- reproduce the issue

- disable logging

- copy & paste your firewall log records here.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...