Jump to content

Unable to generate a PDF report.


watanabe
 Share

Go to solution Solved by Marcos,

Recommended Posts

Hello, everyone.

Unable to generate a PDF report. but Downloading CSV works fine. Therefore, I would like to know the cause of the failure in PDF generation.

# Procedure

  1. select any report in Reports
  2. select PDF in GENERATE AND DOWNLOAD
  3. The dialog "Failed to generate report: Internal server error" will appear.

There is the following log in /var/log/eset/RemoteAdministrator/Server/trace.log.

2021-11-16 04:50:35 Error: CReportPrinterModule [Thread 7f6e721b5700]: ReportPrinter: ReportPrinterTool exited with: No protocol specified<EOL>ReportPrinterTool: cannot connect to X server :2222 [code:1]
2021-11-16 04:50:35 Error: CReportsModule [Thread 7f6e729b6700]: std::exception
2021-11-16 04:50:36 Error: ConsoleApiModule [Thread 7f6e6c9aa700]: 309 Unexpected error while processing GetFileProgress request: ReportPrinter: ReportPrinterTool exited with: No protocol specified<EOL>ReportPrinterTool: cannot connect to X server :2222 [code:1]

# Version

  • ESET PROTECT (Server), Version 8.1 (8.1.2209.0)
  • ESET PROTECT (Web Console), Version 8.1 (8.1.221.0)
  • CentOS (64-bit), Version 7.9.2009
  • Update module    1077 (20200622)
  • Translation support module    1893 (20211026)
  • SysInspector module    1280 (20201022)
  • SSL module    1062 (20210906)
  • Push Notification Service module    1122.2 (20211104)
  • Configuration module    1981.5 (20211103)

# Remarks

I tried [KB6794], but it didn't change the result.

Link to comment
Share on other sites

  • Administrators
  • Solution

Please check if xvfb service is running by running the following in the terminal:

systemctl status eraserver-xvfb

If it's running, execute the server repair task by running /opt/eset/RemoteAdministrator/Server/setup/installer_backup.sh.

Should the problem persist, please raise a support ticket.

Link to comment
Share on other sites

The xvfb service is running.

I did the following and it fixed the problem.

1. get server backup
2. run installer_backup.sh
3. eraserver service restart

Thank you for your swift response. You've been very helpful.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...