Jump to content

Why do Netbios-requests get blocked from ESET firewall?


Recommended Posts

I use ESET IS Ver. 15.0 with Windows 10

I have many entries in the Protection => Troubleshooting Assistant.

Several Netbios requests to port 137 and 138 are blocked there. I think it's because there is a standard entry for this in the ESET firewall. The same applies to SSDP requests (UPnP) to port 1900 and multicast DNS requests to port 5355

Why are all these requests blocked? The Netbios inquiries are actually there to ensure that the devices can be found in the network. Do you still do that then? Is this a security problem or why are these requests being blocked?

 

Link to comment
Share on other sites

Verify that NetBIOS settings are set to Win 10 default for network adapter IPv4  connection setting per below screen shot.

Eset_NetBIOS.thumb.png.70cfca86cbae348328836f41d7449efa.png

Link to comment
Share on other sites

23 hours ago, isd said:

Several Netbios requests to port 137 and 138 are blocked there.

Check your current network connection identification in Eset Network settings. If it is set to Public profile, the Eset firewall default rules pertaining to NetBIOS; i.e. ports 137-139, and 445, will block all incoming NetBIOS traffic. This is because when the Public profile is used, no local network devices are trusted.

By default, the Win 10 firewall is set to the Public profile. This results in all local device network sharing options being disabled. If you overrode this option via Win 10 Network Connections setting , this would explain why Eset firewall is alerting about incoming NetBios traffic.

You have two options here:

1. Reset Win 10 Network Connections settings back to default; i.e. no file of device sharing, which will in turn, eliminate the Eset firewall blocked NetBIOS traffic. This is strongly recommended since Win 10 requires you to manually set which files and devices are to be trusted.

2. Set current network connection identification in Eset Network settings to "Home or office network" profile. This will then allow all NetBIOS network traffic.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...