Jump to content

Com port (Serial Port) being blocked by ESET


Recommended Posts

Hi there,

Strange issue.  I am using a Serial-USB adapter and have found it is being blocked by ESET.  I've tried changing com port numbers, disabling then re-enabling, uninstalling then reinstalling drivers (and have the latest drivers from FTDI).  If I 'Pause Firewall (Allow all traffic)' then I can receive info from the com port without issue.  I have an old laptop that is set up (theoretically identically) to the desktop I have issues with and it allows com port access without a problem.  I don't have 'device control' turned on on either machine and both have the latest ESET versions.

I should also note that the com port does exist in Device Manager and have tried to access it via Putty, Tera Term and even wrote a python script (all say 'Access Denied').  It is definitely an ESET (or somehow Defender) issue, not hardware.

Any ideas?

Cheers

 

Edited by Sylvester
Added details
Link to comment
Share on other sites

OK, slightly more info.  I told HIPS to log things and get this when I try to connect to  the port:

Time;Application;Operation;Target;Action;Rule;Additional information
30/10/2021 3:12:01 pm;C:\Program Files\Logitech\Gaming Software\LWEMon.exe;Get access to another application;C:\Program Files\ESET\ESET Security\egui.exe;Blocked;Self-Defense: Protect ekrn and egui processes;Terminate/suspend another application,Modify state of another application,Get access to another application

 

Link to comment
Share on other sites

  • Administrators

Is re-enabling HIPS, temporarily disabling only self-defense and rebooting the machine enough to make the problem go away?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...