Jump to content

Premium Security - Anti Theft


ForceRecon
 Share

Recommended Posts

I have the new option anti-theft available. When I click to go to the site it prompts me to install anti-theft with 3 easy steps ( I have premium this should not happen ) The first time I tried to follow the installation I thought well maybe there is a little file that needs to be added.. Once I downloaded it and tried to install it, it said I already have the latest version. Kinda made sense since premium should come with it. No matter what I do when I click on the anti-theft it just takes me back to that page to download and install Internet Security the 2nd upgrade from ESET NOD 32. I have tried everything I can think of. Any suggestions?

Thanks

Link to comment
Share on other sites

It looks as though something on the backend synced.. I just tried connecting to anti-theft again just to see if there was anything else I could try and once I logged in my device showed up.  So this seems to be working now.

One question regarding anti-theft. When I add this to my home PC, which unless the house is broken into and stolen. Should I use the same phantom account name? or should all devices have their own phantom device name?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...