Jump to content

Archived

This topic is now archived and is closed to further replies.

geminisam

Slow Access To External Peripheral Containing Pictures When Ess Active

Recommended Posts

Please make the same steps as geminisam too find out where is the problem.

But at first you can also try to deactivate ESET protection completely and find out if the problem is gone.

Share this post


Link to post
Share on other sites

Ok, I read, read, read, and finally understand what you mean in your previous post, I will try this tomorrow, I am done for today, good night, and thank you for your help and patience ^_^

Share this post


Link to post
Share on other sites

Here the screenshots:

post-3952-0-57931200-1407787796_thumb.pngpost-3952-0-04333600-1407787833_thumb.png

 

At the marked things you can set the options.

Share this post


Link to post
Share on other sites

Post #11 was from me and about #15: Configure ESS like this (look at your picture here from #4 if you don't know where) and test it with every configuration:

 

real-time protection only of external devices (see pic and #4) real-time protection  HIPS

  • deactivated |  activated | activated (only real-time access to removable drives deac.)
  • whatever |  deactivated | activated (complete real-time protection deactivated)
  • activated |  activated | deactivated (only HIPS deactivated)
  • deactivated |  activated | deactivated
  • whatever  |  deactivated | deactivated (all deactivated)

 

Hello

 

I finally found enough time to do your test test procedure :)

 

Tests conditions were :

 

Offline computer

Reboot after each change for "HIPS" and "Removable media" settings changes

Camcorder turned off and USB cable disconnected after each try

 

Procedure :

=> Computer placed in condition (reboot included if needed) => Usb cable connection => Camcorder "ON" => Windows dialbox : "open directory" / Eset dialbox : "analyse another time" => Navigate to DCIM subfolders => Copy of one of DCIM subfolder onto computer

 

Here are the results for each try, I tested DCIM subfolder access rapidity and copy transfers speed

 

1 : Slow, 240 KB/S

2 : Instant, 30 MB/S (I choosed desactivated for removable media)

3 : Slow, 50 KB/S

4 : Slow, 46 KB/S

5 : Instant, 34 MB/S (I choosed desactivated for removable media)

 

So, the relevant setting that modify results is "real time protection", I suppose I will have to pause it each time I would like to access/copy to my camcorder content. :unsure:

Share this post


Link to post
Share on other sites

Good. Nice test.

 

So, the relevant setting that modify results is "real time protection"

Yeah, I agree. The problem is "solved" if the "real time protection" is completely deactivated, but the "removable media access" is not the problem. So the problem must be elsewhere in real time protection.

 

 I suppose I will have to pause it each time I would like to access/copy to my camcorder content. :unsure:

Yes, but this is of course no real solution for the problem and you will lose a big part of the protection for a short time.

 

As I said the problem must be elsewhere in real time protection and so I would suggested to make a new test again:

 

At first activate all options again if not already done. Then test the copying again with every of this configurations, but activate the previous option again before deactivating the next option, so that you only have one option deactivated at the same time.

 

Try it with every of this options of the real-time-protection deactivated:

  • Deactivate only "Scan on file open"
  • Deactivate only "Scan on file creation"
  • Deactivate only "Scan on file execution"
  • Deactivate only "Media to scan: Device control"

BTW I don't really know what the difference between the following options is:

post-3952-0-38672100-1408886869_thumb.png

Share this post


Link to post
Share on other sites

Hello

 

Still nod dead, and found enough time to do tests twice :

 

So, as you asked :

  • Deactivate only "Scan on file open"

=> Takes around 05 seconds to go to one photo to another one when viewed directly on camcorder

=> Reaches 20 Mo/sec when copy/paste a photo directory from camcorder to computer

 

  • Deactivate only "Scan on file creation"
  • Deactivate only "Scan on file execution"

=> Same results for both cases :

=> Takes 25 seconds to go to one photo to another one

=> Reaches 400 Ko/s in copy

 

  • Deactivate only "Media to scan: Device control"

=> Instant opening of photos

=> Reaches 36 Mo/s in copy

 

So, here again, the setting that modify the best the results is the Device Control.

And, maybe the translation in french will help you to understand the difference between the two settings :

 

 

Media to scan : Device control => Support à analyser : Contrôle de périphérique

Scan on : Removable media access => Analyser quand : Accès aux supports amovibles

 

I have an idea about the first, I think ESET monitors how the integrated peripherals controler of windows reacts on peripherals changes (plug, unplug, settings changes)

For the second, I think ESET reacts by itself on removable medias.

Share this post


Link to post
Share on other sites

Ok, at first thanks for your test.

So realtime protection > "Device Control" is the bad guy. ;)

 

Now I'm at my wits' end... I mean I have nothing more ideas how you can narrow down your issue. Maybe Marcos or another ESET moderator can say more about it.

But just a question I don't asked until now (or I forgot your answer...): Does the issues only appear with these specific camcorder or does it also affects other removable drives? (just try it e.g. with an USB)

 

And about the French translation... :unsure:

Well..., I'm not French and the way I translated it in my native language also don't made me smarter...

 

But your assumption about the difference may be right.

But on the other hand also Local drives are listed at the left and they won't be plugged or unplugged (so often), so...

 

My idea was that the left specifies the "Where to scan" and the right specific the "What to scan (respectively on what actions)". But if this is so, then the two options would be redundant, because if the where and the what for removable devices is the same. (Scan where? On removable device(s)., Scan what? The removable device.) - If you know what I mean...

Share this post


Link to post
Share on other sites

Deactivate only "Media to scan: Device control"

Thanks, this is actually a bug in v8 beta and the check-box should be called "Removable media". Try disabling only "Removable media access" box while leaving "Device control" box checked. If that helps, it means it takes time for the system to allow scanning the boot sector of the removable medium. In such case, the box should be left unchecked.

Share this post


Link to post
Share on other sites

Ah ok thanks for your reply. So with "removable media access" activated it scans the boot sector...

Share this post


Link to post
Share on other sites

Hello

 

Did some more tests, as you asked me to

 

So, this slow down does not occur on other external devices, tested on 3 Hard drives (NTFS/FAT32), and a USB to µSD adapter with 4GB µSD formated in FAT32, as the camcorder is too.

 

I paused the permanent protection to copy the whole DCIM folder and all its subfolders and pictures onto the µSD

After that, I unplugged both the camcorder and the µSD.

Then, I plugged on another USB port the µSD again, and proceeded as I normaly do with the camcorder, "scan later" in ESS dialbox, and "open directory" in windows dialbox, then exploring the pictures folders and their content is instant, and copy from µSD to HDD reached and average 16Mb/s, this is lower than with the camcorder but thinking this is due to µSD class

 

Then, I turned protection back ON, and plugged another time, and proceeded as before, exploring and copying.

The pictures exploration is instant too, and the copy reached the same average 16Mb/s

 

 

Then, I did as Marcos said, unboxing only "Removable media access" box while leaving "Device control" box checked.

Exploring is slow, and opening a picture takes about 30 seconds, (it start showing picture, dirty at 20 seconds, and the picture is clear at 30)

Share this post


Link to post
Share on other sites

16 MB/s mayb is okay, depending on what speed class you have.

 

Then, I did as Marcos said, unboxing only "Removable media access" box while leaving "Device control" box checked.

Exploring is slow, and opening a picture takes about 30 seconds, (it start showing picture, dirty at 20 seconds, and the picture is clear at 30)

And what device were you using?

 

And if it was slow in that case, when you had enabled the complete protection then it was fast?

 

Then, I turned protection back ON, and plugged another time, and proceeded as before, exploring and copying.

The pictures exploration is instant too, and the copy reached the same average 16Mb/s

Share this post


Link to post
Share on other sites

So, this slow down does not occur on other external devices, tested on 3 Hard drives (NTFS/FAT32), and a USB to µSD adapter with 4GB µSD formated in FAT32, as the camcorder is too.

Okay, this is strange. Maybe it has something to do with the specific camcorder.

Share this post


Link to post
Share on other sites

I did my tests while writing results with micro SD and Camcorder yesterday.

 

With full protection, or partial protection, there is no difference on MicroSD, exploring and copying are at normal speed (I do not know the micro SD class I have)

 

There is no difference too with camcorder between full protection and partial, this is slow, in both cases.

 

 

As we saw earlier that the bad guy was the "device control", and as this is not the parameter Marcos said me to switch off, then the results was predictable

 

 

I agree on the camcorder, maybe somthing special with it, I formated it at the beginning of the tests of this thread. So filesystem and sector boot should be "clear" (faults safe).

 

But, if I remember well, in older versions of ESS, I did not have such slow downs.

 

I could install an older version (if still downloable somewhere ?) on a machine to test ...

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...