Jump to content

64 bit installer won't work on particular 64 bit server - but works on others

Go to solution Solved by jroseace,

Recommended Posts

In the last few days we've set up a new instance of ESET Protect on-prem server, and created both a workstation installer, and a server installer. Both work fine on most machines, but I have 1 Server 2016 x64 machine that complains when I try to use the x64 server all-in-one installer. I get the 'Incompatible Operating System' message;

'The ESET Server Security for Microsoft Windows Server is not intended for your operating systems'.

This is really puzzling, as I've tripled-checked everything; it's a 64 bit installer going on a 64 bit 2016 server. I think initially I might have mistakenly tried to install the workstation installer on that machine, but realised my mistake immediately. Even after a restart, then trying the correct installer, I keep getting the same error, though.

The same installer has worked fine on about 10 other 2016 servers, so I know it works. To further clarify, we don't even have any 32 bit servers, so this couldn't be an issue.

Does anyone have any suggestions?

Many thanks.


Link to comment
Share on other sites

Update: I've found a couple of other servers that are refusing the same installer. They all have in common that they are RDS servers. Other servers that aren't RDS seem to be fine.

We used to use the same ESET File Security installer for all servers, and this installed on evertything no problem.

This time we're installing ESET Server Security, which so far seems to go on fine, but seemingly not on RDS servers. As an experiment I created an ESET File Security installer on the new server, and tried that - same deal - won't go on.

What is the recommended ESET product to use on RDS servers?

Link to comment
Share on other sites

  • Solution

Thanks Marcos. I got around it in the end by just deploying the agent, then running the product install as a task. Not sure why RDS servers don't like the all-in-one installer, but there we are.


Thanks again for the assist.

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...