Jump to content

Suddenly mobile phone got locked - screen always turns off, cannot type PIN to unblock, 2 SIMs inside

Go to solution Solved by Tomislav,

Recommended Posts

Recently I have figured out my phone Xiaomi Mi Note 10 got locked.

Whenever I try to enter my PIN, the screen goes black and turns off.

Dual-SIM always was in, nothing changed for 2 years of using ESET for Android.

I am completly locked out sitting at home and thinking what has triggered and happend here?

Even if connected to mobile data, and even if I turn off the anti-theft mode in myset online on my PC, nothing changes.

Please, anyone?

Link to comment
Share on other sites

The main problem is the thing that screen cannot be "on" for even a 15 seconds to type the unlock code, it immediately goes "off" (black) and locked.

This is really bad issue here.

Furthermore, I managed once to enter the unlock code - the the error about cannot process data appeared - later on, having mobile data somehow on "active", when I pressed "unlock" button, nothing happened too.

The fact is that few days ago, I noticed when receiving a call, the screen goes black, have to "unlock", enter PIN, and therefore slide with my finger to answer a call.

Moreover, the issue could also be for any user if he is using a VPN like Outline or some other like Cloudflare WARP - as far as it would get different IP which could result to be even a suspicious one too.

Due to my home country, even my regular IP addresses from my mobile carrier or my home ISP are being suspicious.

What has ESET changed recently if there was some update in the Android app?

Nevertheless, I am currently trying and will see, if anything changes when I get both or one of my SIM cards out.

Hopefully, it would not wipe all my data as well.

If somehow I succeed, will write back ... but, from this event I confirm I will not recommend ESET for Android to any of my colleagues anymore.

Kindly, please make an option to delete the app on Android remotely somehow via myeset or something like that in this particular cases.

Edited by Tomislav
more info
Link to comment
Share on other sites

  • Administrators

Do you have 2 SIM cards inserted? Does removing either one or exchanging one with the other make a difference?

At any rate, please open a support ticket with your local ESET distributor and provide them with information about your mobile phone (brand/type) as well as your my.eset.com account email and a link to this topic. The partner should contact ESET HQ then.

Link to comment
Share on other sites

Yes, 2 SIM cards - but no issue for a year, and now what?

Will write back as soon as I remove one of them or try the as You have suggested.


Here, detailed view - private video uploaded to YouTube from my other phone (not used after I got new a year ago).

Link to video what is happening:



And some screenshots ...

Screenshot 2021-09-03 at 12-54-44 ESET Anti-Theft.png

Screenshot 2021-09-03 at 12-55-04 ESET Anti-Theft.png





Screenshot 2021-09-03 at 13-11-44 ESET Anti-Theft.png

Edited by Tomislav
video and photos added
Link to comment
Share on other sites

Okay, will contact my local ESET HQ partner, but they did not provide me licence.

The licence was purchased online via eset.ee website.

Screenshot 2021-09-03 at 13-17-04 ESET Anti-Theft.png

Edited by Tomislav
Link to comment
Share on other sites

Both SIM cards out - again, screen gets locked immediately, not even 5 seconds.

That is the main problem - why does the screen goes off immediately?

Cannot even drag the status bar / notification from top to bottom.

Even when I get to "unlock" button, seems it's not working neither - may I ask why nothing happens when I press the "unlock" button after the unlock code is being typed correctly and network connection is established?

Cannot do nothing here.

Can throw the phone to the trash just like that.

Edited by Tomislav
Link to comment
Share on other sites

Okay, now somehow I managed, I was on unlock screen, entered the unlock code.

Therefore, at my desktop PC I clicked to turn off anti-theft.

Was pushing the button for exit like never before on the phone.

Got back to home screen.

And fastly have went to the "screen side" and deleted ESET Mobile Security application.

Clicked also on the button to clear memmory/cache.

Also wen to Google Play and found it, selected and deleted.

Says: Deinstallation failed - why?

Is the ESET Mobile Security now deleted or not?

Edited by Tomislav
Link to comment
Share on other sites

Now the app cannot be uninstalled, oh my gosh.

I am not sure if I will get back to my home screen if I go to ESET Mobile Security app and follow the instructions from below link for uninstallation:


Link to comment
Share on other sites

And yes, again the same problem as I entered the app to remove it (both sims are out).

Better I haven't followed the instructions :(

Edited by Tomislav
Link to comment
Share on other sites

  • Solution

Alternative uninstall method - worked finally!

1. WiFI on

2. Location on

3. anti-theft.eset.com -

4. Mobile phone at unlock screen

5. went to unlock

6. entered unlock code - nothing happened

7. anti-theft.eset.com - selected turn off anti-theft

8. entered unlock code - woulla I got to home screen

9. went to settings - device administrators - and removed ESET Mobile Security

10. checked and uninstalled anything left from this app


Thank you for protecting my PC well, but not wanting your app back on my phone ever again as far from this event.

Edited by Tomislav
Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...