Jump to content

Eset Firewall Interactive Mode doesn't work after upgrade to v. 14.1.19


Recommended Posts

Just noticed that Eset Firewall Interactive Mode doesn't work any longer after recent upgrade to v. 14.1.19 . The apps that required manual permission before in Interactive mode, or even had such permission in Advanced Rules, now can't access internet. Eset shows no prompt ever at such apps launch. The same apps work fine in Eset Firewall Auto and Learning modes.

As an example, Telegram stopped loading content despite existing "Allow" rule, and no Eset prompt appears at Telegram launch. But there are a lot more apps behaving like this. I tried to delete all Telegram rules, then they get auto created in Learning mode, but Interactive mode still doesn't show any prompts and blocks Telegram. However, it passes all browsers traffic without prompts.

Any way to fix that?

Edited by SamBul27
Link to comment
Share on other sites

  • Administrators

It doesn't look like a general problem, for me interactive dialogs appear even with v14.1:

image.png

The issue was also observed with v14.0, however, the cause is unknown yet.

Please keep the main gui open and then try to invoke an interactive dialog. Let us know if it shows up then.
 

Link to comment
Share on other sites

Posted (edited)

Tested again. After Learning mode created rules for Telegram, I switched to Interactive mode, and Telegram loaded content based on the above new rules. But after I disabled these new rules and restarted Telegram in Interactive Firewall mode, it again couldn't load any content, and no Eset Prompt appeared. So Interactive Mode appears broken in the last release. Didn't happen to me before anything like that. The main Eset GUI is kept open, but it doesn't affect anything.

Edited by SamBul27
Link to comment
Share on other sites

Posted (edited)

Here is the screenshot. Is it possible that Windows may consider such Dialog as a popup and block it? But no recent Windows 10 20H2 updates, last security update installed 2 weeks ago.

Telegram.jpg

Edited by SamBul27
Link to comment
Share on other sites

  • Administrators

Was the ESET main gui open when you launched the messaging application? Asking since it's not visible in the screen shot.

Also just to make sure, did you reboot (not shut down) the system after upgrade to v14.1?

Link to comment
Share on other sites

I am also having the same problem.  I uninstalled and installed the older version then the interactive mode worked ok. When the auto update then updated my system the interactive mode does not work after a resume.

Running Windows 10 20H2 (OS Build 19042.928)

ESET Version 14.1.19.0

Link to comment
Share on other sites

Posted (edited)
5 hours ago, Marcos said:

Was the ESET main gui open

did you reboot

Eset main GUI was open when Telegram was launched. But this is just an example, many apps behave like this. I did reboot the system (not shutdown) to no avail. I rely heavily on interactive mode when running some apps, so its very unfortunate Eset bug, basically doesn't allow me to run quite a few apps, because some of their components must be allowed to access web, while others should not be.

Edited by SamBul27
Link to comment
Share on other sites

Posted (edited)

May be there is a Pre-release Eset Firewall module that fixes the bug? Let us know pls when its released. Juts tried Windows Weather app, and it doesn't load data either. Had to switch to Auto Firewall mode.

Edited by SamBul27
Link to comment
Share on other sites

Posted (edited)
7 hours ago, Marcos said:

It doesn't look like a general problem

The issue was also observed with v14.0, however, the cause is unknown yet.

I just checked Eset settings and found that I'm on Pre-release update channel. I rolled back the last modules update, rebooted, and now I've Interaction Prompts on screen again. Eset version remains the same, and I noticed that Eset Firewall module version 1420 remained also the same, only modules updated on April 28, 2021 were reverted, since there are no modules with that date anymore in the list. So it looks like a different last updated Eset module causes the issue.

I blocked module updates for now. Does it mean that signatures won't be updated either? is there a way to keep updating signatures, while blocking module updates? May be its better to stay on Release channel rather than Pre-release in general?

Edited by SamBul27
Link to comment
Share on other sites

53 minutes ago, SamBul27 said:

Eset version remains the same, and I noticed that Eset Firewall module version 1420 remained also the same, only modules updated on April 28, 2021 were reverted, since there are no modules with that date anymore in the list.

This is weird. I upgraded to ver. 14.1.19 yesterday and my firewall module ver. is 1418 dating to 11/2/2020.

The problem might be you're using pre-release updating and a later dated firewall module is the issue. Set Eset back to regular update channel and this will hopefully solve your issue.

Link to comment
Share on other sites

40 minutes ago, itman said:

I upgraded to ver. 14.1.19 yesterday and my firewall module ver. is 1418 dating to 11/2/2020.

This reply doesn't answer my Q about signature updates, while module updates are blocked.

As to Firewall module, I've 1420 of 02/18/21, and it works very well, so I've no intention to go back to 1418, and in general to older modules, since currently installed pre-release versions work well. It might be an old FW "pre-release", but as soon as I rolled back from April 28, 21 two or three module updates (not the Firewall module), Interactive mode started working properly. So a different module (out of 3 updated on pre-release yesterday) affected this. Hope it narrows the bug search for devs.

Link to comment
Share on other sites

3 hours ago, SamBul27 said:

This reply doesn't answer my Q about signature updates, while module updates are blocked.

How did you block module updates? As far as I am aware of, that option does not exist in the Eset GUI.

Link to comment
Share on other sites

Posted (edited)
6 hours ago, itman said:

How did you block module updates?

By Module Rollback option in Eset Update setup. It suspends module updates until set time or till suspension is revoked. However, this should not stop signatures and other Eset components updates required to provide all claimed protections.

In fact, module updates are seldom, may be once in several months, but signature updates are done many times a day. So it appears to be a bug that suspending module updates also suspends signature and other regular DB updates required for Eset to function effectively.

Edited by SamBul27
Link to comment
Share on other sites

  • Administrators

Suspending updates suspends all module updates, including engine and streamed updates. It's not a bug but how the feature works. Otherwise users would not be able to revert to an older engine that might not be affected by a particular false positive for instance.

The problem with interactive dialogs should not be module-specific; it was also reported with v14.0. Are you able to reproduce the issue with release modules and the problem does not occur with pre-release modules or vice-versa?

Link to comment
Share on other sites

5 hours ago, Marcos said:

Suspending updates suspends all module updates, including engine and streamed updates.

I assume "steamed updates" means Pico updates?

Since Pico updating is the primary method of updating Eset versus module updates, it is definitely something that should not be disabled.

Link to comment
Share on other sites

  • Administrators
Just now, itman said:

I assume "steamed updates" means Pico updates?

Since Pico updating is the primary method of updating Eset versus module updates, it is definitely something that should not be disabled.

Correct, "streamed updates" are "pico updates". Pausing updates means to pause all updates since this feature is used when something wrong has already happened and thus any updates must be prevented until the user resumes updates.

Link to comment
Share on other sites

Posted (edited)
10 hours ago, Marcos said:

Are you able to reproduce the issue with release modules and the problem does not occur with pre-release modules or vice-versa?

I'm currently on pre-release. So I assume, ALL modules installed are pre-release modules, unless not available. I don't have any issues right now with Interactive dialog, after reverting to older versions of modules updated April 28, 2021. You know what modules were released that date, I don't remember. So for me the missing Interactive dialogs bug is clearly module specific, and its NOT caused by firewall module. When I have time, I'll reverse to release modules and see, but why do that, if even previous pre-release modules don't cause such bug on my end?

I think, the devs should allow sig updates despite module updates are on hold. I mean, some folks still use very old Eset versions, and still get sig updates.

Edited by SamBul27
Link to comment
Share on other sites

2 hours ago, SamBul27 said:

So for me the missing Interactive dialogs bug is clearly module specific, and its NOT caused by firewall module. When I have time, I'll reverse to release modules and see, but why do that, if even previous pre-release modules don't cause such bug on my end?

The only other "culprit" I can think of would be the Network protection module. Mine on regular release update channel is ver. 1688.4 dated 3/31/2021.

BTW - do you have the B&PP secure all supported browsers setting enabled? That also is a possible "culprit."

Edited by itman
Link to comment
Share on other sites

10 hours ago, itman said:

Network protection module

Mine is the same, so its obviously a mix of release and pre-release modules in that update mode. B&PP in my tests doesn't affect Interactive mode alerts showing up.

Link to comment
Share on other sites

Posted (edited)

I just updated all modules, still being in pre-release mode. The bug seems to be fixed for now, Interactive notifications are working again. The modules updated today were:

Databases for advanced antispam module: 6819P (20210430)
Rapid Response module: 18186P (20210430)
Detection Engine: 23222P (20210430)

Edited by SamBul27
Link to comment
Share on other sites

  • 5 weeks later...

I have the same problem now :((
The interactive mode does not work anymore
And with version 14.1.20.0!

Moteur de détection : 23386 (20210531)
Module de réponse rapide  : 18353 (20210531)
Module de mise à jour  : 1023 (20200701)
Module d'analyse antivirus et antispyware  : 1574 (20210423)
Module d'heuristique avancée  : 1207.1 (20210421)
Module de prise en charge des archives : 1319 (20210525)
Module de nettoyage  : 1218.2 (20210512)
Module Anti-Stealth  : 1174 (20210408)
Module Pare-feu : 1418 (20201102)
Module ESET SysInspector  : 1281.1 (20210407)
Module de prise en charge de la traduction  : 1861 (20210524)
Module de prise en charge HIPS  : 1415.1 (20210416)
Module de protection Internet  : 1425 (20210416)
Module de filtrage de contenu Web  : 1081 (20210217)
Module antispam avancé  : 7892 (20210512)
Module de base de données  : 1112 (20200928)
Module de configuration (39) : 1958.3 (20210525)
Module de communication LiveGrid  : 1110 (20210426)
Module d'ESET Specialized Cleaner  : 1014 (20200129)
Module de protection des paiements et bancaire : 1219 (20210430)
Module de détection et de nettoyage de rootkits : 1031.1 (20210401)
Module de protection réseau : 1688.4 (20210331)
Module d'analyse des vulnérabilités du routeur : 1073 (20210422)
Module d'analyse des scripts : 1096 (20210419)
Module Périphériques connectés au réseau domestique : 1040 (20200728)
Module de prise en charge du protocole de chiffrement : 1061 (20210510)
Bases de données pour le module antispam avancé : 6912 (20210531)
Module de support pour l'inspection comportementale profonde : 1113 (20210513)
Module d’apprentissage machine avancé : 1102 (20210518)
Module de télémétrie : 1061.1 (20200706)
Module d'intégration du centre de sécurité : 1029.1 (20210113)

Link to comment
Share on other sites

Yes:


image.png.517e7534437f7ca6bdbb90318ec0a0dd.png

(I have been an eset user for many years and everything was working fine until a few days ago).

So I think it's a recent bug.
Just in case, here is my version of Windows:

image.png.e9fa2124c8a5f9bb137576da48de11c5.png

Link to comment
Share on other sites

  • Most Valued Members
22 minutes ago, merlin666 said:

Yes:


image.png.517e7534437f7ca6bdbb90318ec0a0dd.png

(I have been an eset user for many years and everything was working fine until a few days ago).

So I think it's a recent bug.
Just in case, here is my version of Windows:

image.png.e9fa2124c8a5f9bb137576da48de11c5.png

Have you tried pre release updates to see if it fixes it?

Link to comment
Share on other sites

  • Administrators

You can also try uninstalling ESET and installing the latest version from scratch. Should the problem persist, please open a support ticket with your local ESET distributor.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...