Jump to content

Product version status and packet installer issue


Recommended Posts

Hello,

i have the following problems with our ESET Protect environment.

 

A Few weeks ago i update the EMC to ESET Protect and after a 2 weeks i noticed that the "Product version status" dashboard was showing me the "Agent" status in grey instead of green or red. 

 

 

I am using ESET PROTECT (Server), Version 8.0 (8.0.1258.0)  and for the clients ESET Management Agent 8.0.1238.0

 

And the second problem:

 

When i try to create a new "all in one installer package" i cant find any version for my client (ESET Endpoint Security 8.0.2028.0) the repository is not empty i find packages for ESET Server Security.

 

King Regards

 

 

Agent grey.jpg

Edited by Dud3
Link to post
Share on other sites
  • ESET Staff

Could you please check EP's trace.log for possible network-related issues? It seems that communication with ESET repository servers might be failing and thus EP is not able to decide whether installed version is latest or not.
Also what platform, DB type are you using? What was previous ESMC version used before upgrade?

Link to post
Share on other sites
  • 3 weeks later...

Hello MartinK,

 

thanks for your reply.

I am using MSSQL Server 2014.

 

I uploaded a short summary of logs from a client

 

From the client i can reach the server on port 2222, tested with telnet.

 

Quote

What was previous ESMC version used before upgrade?

How do i determine this?

 

Best Regards

log.txt

Link to post
Share on other sites
  • ESET Staff

Actually I was referring to EP Server's logs, located in C:\ProgramData\ESET\RemoteAdministrator\Server\EraServerApplicationData\Logs in case of EP for Windows, but in case there are only clients that are not able to connect to EP, it might also explain why version check is not working as intended.

From provided logs it is fairly clear that AGENT on client devices is not able to connect to EP because of DNS-resolving issue - could you double check that hostname as was printed in logs is correct and can be actually resolved to IP address on client device?

Link to post
Share on other sites

Hello MartinK,

 

i uploaded the trace.log from the EP Server.

 

I put a VM in the same subnetwork as the EP server and the agent status is still unknown /grey.

I also triple checked the name resolving, on the VM with nslookup and ping. The client can resolve the IP of the EP Server.

 

The problem is not only on windows clients also on MAC OS, Windows 10 Clients and Windows Servers.

 

Could you tell me what i should check within the configuration policy's?

  

Best Regards

 

trace.log

Link to post
Share on other sites
  • ESET Staff
5 hours ago, Dud3 said:

@MartinK are the provided information helpful?

Unfortunately not, as it contains only 3 minutes of data, and synchronization with ESET repository servers is most probably not covered, as it happens only once an hour ... but I have passed to others, whether they have not seen such behavior previously.
But it might help to also provide trace log covering first minutes after service EP restart, there is a higher chance it will cover also possibly problematic part.

Link to post
Share on other sites
  • ESET Staff
On 5/6/2021 at 11:54 AM, Dud3 said:

@MartinK

i hope these a helpful and give us a hint about the problem

Checked logs and there are entries like this:
 

2021-05-06 09:37:38 Information: CRepositoryModule [Thread 163c]: CMetadataProcessorV3:http://repositorynocdn.eset.com/v1/com/eset/apps/business/era/agent/metadata3 is not synchronized (not exist in repository)

and alternatives for each product, indicating that indeed synchronzation with ESET repository servers is not working.
Could you please check you can actually download file from URL: http://repositorynocdn.eset.com/v1/com/eset/apps/business/era/agent/metadata3 on the same machine where EP service is running? Is there any firewall that could be blocking requests? I can see that non-standard ESET repository url is used, the one that directs requests to only ESET datacenters and not public CDN providers. Also please make sure HTTP proxy is properly configured and running, in case it is used.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...