Jump to content

Cannot connect to wifi if ESET Endpoint installed


Recommended Posts

Our customer feedback that their users cannot connect to public wifi with ESET Endpoint Antivirus installed. The wifi has a portal where they need to login, same like in a hotel. When ESET installed this login page won't show up, But if disable real-time protection, it works as per normal. Ask user to change settings is not a good idea as they are not IT expert. 

Link to comment
Share on other sites

  • Administrators

Strange that you've narrowed it down to real-time protection. Is it enough to pause it? Which of the events in the advanced setup must be disabled (scan on open/create/execute) for the issue to not manifest?

Link to comment
Share on other sites

On 3/31/2021 at 7:50 PM, Marcos said:

Strange that you've narrowed it down to real-time protection. Is it enough to pause it? Which of the events in the advanced setup must be disabled (scan on open/create/execute) for the issue to not manifest?

Hi Marcos,

The customer told me he just right click the eset icon and pause the protection, then he can see the wifi portal and connect to the wifi.

image.png.76e9b92a13f7b4338a20a81f7f597a70.png

Link to comment
Share on other sites

  • Administrators

It's weird cause "pause protection" doesn't affect things in other way then that files are not scanned for malware. Is it enough to pause web access or real-time protection, one at a time?

Link to comment
Share on other sites

  • 1 month later...
Posted (edited)

Is there perhaps an update on this?

I have a bunch of sales staff with laptops running ESET endpoint and they are unable to join any other Wi-Fi network besides the corporate network.

Which is a mess, since they need to have connectivity when at client sites.

Pausing real-time protection is not a fix.

ESET is up for renewal soon and if this doesn't get fixed I'm moving to Sophos

Edited by jeeva
added a line
Link to comment
Share on other sites

  • Administrators
21 minutes ago, jeeva said:

Is there perhaps an update on this?

Have you already raised a ticket with your local ESET distributor to troubleshoot the issue?

Does pausing Web access protection make a difference? If not, what about temporarily disabling protocol filtering in the advanced setup? Or it's another feature or setting that needs to be turned off in order for the issue to go away?

Link to comment
Share on other sites

Posted (edited)

First, refer to this Eset KB article: https://support.eset.com/en/kb3116-new-network-connection-detected-in-eset-endpoint-security . Although it refers to ver. 6, it is also applicable to later Endpoint versions.

As I see it, notebooks/laptops being used on the corp. network are configured to use the Eset Home/Office network? When those devices are used outside the corp. network such as to connect to a public wi-fi network, Eset Network processing should be showing an alert that a new network connection has been detected and what Eset Network profile should be used for this connection. For any wi-fi connection especially a public wi-fi connection, the Public profile should be selected. What I suspect is happening is these devices have the Eset Network Firewall setting -> Known networks -> Protection type of new networks not set to "Ask user" or "Mark as public." Finally, note the Eset default for this setting is to "use Windows setting" which defers to the existing Windows firewall configuration. As such, the issue might be related to that setting.

Edited by itman
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...