Jump to content

Allowing a specific program through the firewall


Recommended Posts

I wrote to ESET tech support, but the answer given to my issue had nothing to do with the actual issue I was asking about, so...

 

From within the game Wreckfest (Steam) I can host a game with no issues with ESET Internet Security v14.0.22.0 but if I try to run Wreckfest's dedicated server (separate from the game itself), no one can see my game online unless I disable ESET's firewall.

 

I have already tried putting ESET into interactive mode and given the dedicated server permission, but it still blocks it.

 

How/Where can I see a list of programs that ESET's firewall is allowing/blocking so that I can set it up to allow the dedicated server to pass through instead of blocking it?

 

BTW, I explained the exact same issue to ESET tech support and was referred to an article on how to stop certain programs from being detected in a virus scan. A worthless answer.

 

Thank you!

 

Bill

Link to comment
Share on other sites

36 minutes ago, Bogey62 said:

How/Where can I see a list of programs that ESET's firewall is allowing/blocking so that I can set it up to allow the dedicated server to pass through instead of blocking it?

Open Eset GUI and navigate to Network Protection section. Refer to the Troubleshooting wizard setting. This will show all firewall blocked connections for a certain interval. The default interval is the last 15 minutes.

39 minutes ago, Bogey62 said:

From within the game Wreckfest (Steam) I can host a game with no issues with ESET Internet Security v14.0.22.0 but if I try to run Wreckfest's dedicated server (separate from the game itself), no one can see my game online unless I disable ESET's firewall.

You could switch the firewall Filtering mode to Learning mode just prior to switching to  Wreckfest's dedicated server mode. This will auto create any required firewall rules. Note: there is a risk here in doing so; especially with a multi-player game. Once the multi-player game session ends, switch Filtering mode back to either Automatic or Interactive mode.

Link to comment
Share on other sites

46 minutes ago, itman said:

Open Eset GUI and navigate to Network Protection section. Refer to the Troubleshooting wizard setting. This will show all firewall blocked connections for a certain interval. The default interval is the last 15 minutes.

You could switch the firewall Filtering mode to Learning mode just prior to switching to  Wreckfest's dedicated server mode. This will auto create any required firewall rules. Note: there is a risk here in doing so; especially with a multi-player game. Once the multi-player game session ends, switch Filtering mode back to either Automatic or Interactive mode.

Thank you for the quick response.

 

I am looking at the Rules section now and have found two entries for Wreckfest. It was only allowing communications In, but not Out on one of the three ports the server needs. I edited it to allow In/Out on all three ports that the server needs. That may be my issue. I will test it tonight when I have a friend online that can check the server's visibility for me.

Link to comment
Share on other sites

4 hours ago, Bogey62 said:

I am looking at the Rules section now and have found two entries for Wreckfest. It was only allowing communications In, but not Out on one of the three ports the server needs.

If the Eset firewall was set to default Automatic filtering mode, all outbound network traffic is allowed unless a rule exists that specifically blocks that traffic.

If the firewall was previously set to Interactive filtering mode, you should have received a previous alert on Wreckfest outbound network traffic.

If Wreckfest network connections persist in multi-player mode, temporarily disable the Eset firewall. If the issues persist with the firewall disabled, your issue is not being caused by the Eset firewall.

Link to comment
Share on other sites

7 hours ago, itman said:

If the Eset firewall was set to default Automatic filtering mode, all outbound network traffic is allowed unless a rule exists that specifically blocks that traffic.

If the firewall was previously set to Interactive filtering mode, you should have received a previous alert on Wreckfest outbound network traffic.

If Wreckfest network connections persist in multi-player mode, temporarily disable the Eset firewall. If the issues persist with the firewall disabled, your issue is not being caused by the Eset firewall.

I set the firewall to allow the three Wreckfest ports both directions with UDP/TCP and now it works.

 

Thanks for your input, it's greatly appreciated.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...