Jump to content

Email notification error: "An error occurred while sending the test notification."


Recommended Posts

I'm currently running a trial of ESET NOD32 Antivirus 14.0.22.0 on Windows 10 Pro x64 20H2. I'm not having any other issues with the product, so hopefully this will be my last thread!

I can't get email notifications to work. When I hit "Test" under TOOLS > Notifications > "EMAIL NOTIFICATIONS", I get "An error occurred while sending the test notification." with no indication of what the error is.

- No log entry is created explaining what the problem is.
- I've quadruple-checked my SMTP server host name, my username, and password.
- I've tried using the SMTP server's IP address (rather than hostname).
- I've tried disabling Windows Firewall.
- I've tried disabling "Enable TLS".
- I've tried excluding the SMTP server IP address from protocol filtering.
- I've tried setting both "CERTIFICATE VALIDITY" settings to "Ask about certificate validity" (rather than "Block communication that uses that certificate")

I have a bunch of other applications that send email from my PC just fine, so this is not a new thing to me.

What could be the issue?

Link to post
Share on other sites
  • Administrators

Please provide:
- logs collected with ESET Log Collector (set up the SMTP server first)
- a pcap log created with Wireshark while attempting to send a test email.

I'd recommend installing ESET Internet Security instead of ESET NOD32 Antivirus since it supports network communication logging and also protects you from bots and exploitation of unpatched vulnerabilities in network protocols. Moreover it provides also antispam and Anti-Theft features.

Link to post
Share on other sites

I see the issue now. The ESET NOD32 Antivirus process ekrn.exe is attempting to use SMTP on port 25 (whether or not I have the "Enable TLS" setting enabled). My SMTP server uses ports 465 (SSL/TLS) and 587 (non-SSL) only. And the interface doesn't allow me to specify a port (I tried tacking :465 on the end of the hostname, to no avail).

Link to post
Share on other sites
35 minutes ago, Outcast said:

And the interface doesn't allow me to specify a port (I tried tacking :465 on the end of the hostname, to no avail).

According to NOD32 Online help, it should work per below screenshot:

NOD32_Email.thumb.png.eb8953ac4155a146f0c441c2bb2385c2.png

 

Link to post
Share on other sites
Posted (edited)

Because my mail server only uses SSL/TLS on port 465, I hadn't tried port 587 in that manner, only 465. As it turns out, 587 (i.e. host.name:587) works, but 465 (i.e. host.name:465) does not. Strange.

Edited by Outcast
Link to post
Share on other sites

Might be that the "SSL/TLS" option overrides default SMTP port assignments. Disable the option and non-encrypted traffic being sent via port 587. Enable the option and encrypted traffic sent via port 587.

Link to post
Share on other sites
Posted (edited)

I found that using "host.name:587" actually works whether or not "Enable TLS" is on. Since my server doesn't support SSL/TLS on 587 at all, I can only guess that when it's on, the application tries using TLS and then automatically backs off to plaintext.

Edited by Outcast
Link to post
Share on other sites

Maybe this is an explanation:

Quote

What is Port 587 Used For?

Port 587 is the default port for SMTP submission on the modern web. While you can use other ports for submission (more on those next), you should always start with port 587 as the default and only use a different port if circumstances dictate (like your host blocking port 587 for some reason).

Port 587 also supports TLS, which means that you can securely submit mail.

What is Port 465 Used For?

Port 465 was originally registered for SMTPS (SMTP over SSL). After a brief stint in that function, port 465 was reassigned for a different use and deprecated.

Despite that fact, many ISPs and cloud hosting providers still support port 465 for SMTP submission.

https://kinsta.com/blog/smtp-port/

Edited by itman
Link to post
Share on other sites

I can tell from reviewing packet logs that the traffic on port 587 is indeed encrypted when "Enable TLS" is enabled, and yet it works. So my email server does support TLS on port 587, meaning that my web host's documentation is flatly wrong. Quite annoying.

Thanks for the replies!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...