Jump to content

Suggested improvement to Restore Window Layout


rlcronin
 Share

Recommended Posts

I used to connect my monitor to my PC with a standard (dual-link) DVI cable. I recently switched to a DisplayPort cable. Ever since, when my PC turns itself on overnight to run various scheduled tasks (at which time the monitor is OFF), if a nod32 update comes through during the time it is up, the next morning when I wake the PC up for my work day and another nod32 update comes through, the alert that usually pops up in the lower right corner of the display instead pops up in the middle of the screen (at about the point that the lower right corner WOULD be if the monitor resolution were standard VGA). I presume the display being off at the time the overnight update comes in makes nod32 think the screen is standard VGA and so it adjusts the alert position accordingly.

 

To restore the alert to where I want it I have to edit the registry and set the DesktopAlertPosition1 and DisplayAlertPosition2 to hex ffffffff. I suppose I could avoid it altogether if I were willing to leave the monitor on all the time, but that would waste electricity and I am loathe to do that.

 

This is annoying!

 

It'd be nice if this could be fixed so that it didn't happen in the first place, but if not, it'd be nice if the ResetWindowLayout command could be enhanced to reset the alert position, perhaps optionally (so those who have deliberately put theirs in a non-standard place and like it that way don't get annoyed).

--

bc

Link to comment
Share on other sites

Hello,

 

As a workaround you can set this when you turn off your monitor: See Pic

Under Notification options in Advanced Setup

 

I only suggested it because you're demeanor sounds like you really hate this anomaly.

 

Sorry for you're troubles.
:)

 

post-1101-0-56073900-1404331784_thumb.jpg

Link to comment
Share on other sites

I didn't intend to imply it was that serious. In the grand scheme of things, I'd classify it as a minor annoyance (and doubleclicking the .reg file I created to apply the fix isn't that much of a burden). But life would be ever so slightly more fun if I didn't have to deal with this, so if sometime there's a rainy day with nothing better to do, maybe someone at Eset could have a wee look at it. Thanks.

--

bc

Link to comment
Share on other sites

Awesome rlcronin. Thanks for sharing with us, and i am almost positive this thread will get to the right people.

Enjoy your day. :)

Link to comment
Share on other sites

Researching this further, I've discovered (and tested) a workaround for this issue. I'm posting it here in case anyone else has the issue and would like to get around it. I'd still like some kind of fix for this in nod32, although since the cause of this is a less-than-ideal Windows design decision regarding how to deal with DisplayPort devices when they get turned off, I'd understand if ESET shrugged it off as a Microsoft issue.

 

Here's the advice I found. It did work for me. However since it turns off USB selective suspend altogether, it can have possibly undesirable side-effects depending on the stable of USB devices you have and whether or not disabling the ability to selectively suspend them would cause an impact for you (e.g. as it might on a laptop running off battery). Why exactly a setting for *USB* selective suspend has an effect on how Windows deals with a non-USB DisplayPort monitor I'll leave to you to scratch your head about what Microsoft was thinking when it did this! Oh and despite the fact that the advice talks about Windows 7, it works for Windows 8.1 as well.

 

Go to Control Panel, Power Options, Edit the plan you use by clicking Change Plan Settings, once here click Change Advanced Power Settings. Once there, go to USB Settings, open the menu by clicking the + open the next menu named USB Selective Suspend Setting and disable it. Once this is disabled Windows 7 will no longer adjust your display setup when a display is turned off.

Edited by rlcronin
Link to comment
Share on other sites

After several days of living with it, it seems the USB selective suspend setting does help, but doesn't completely solve the problem. It still happens on occasion. So an ESET solution of some sort would be appreciated.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...