Jump to content

Greylisting for ESET Mail Security Blocking Local Anonymous TLS


Recommended Posts

We have been receiving and excessive amount of spam (although ESET Mail Security has been filtering it), so I thought I'd try enabling greylisting. Doing so has drastically reduced the amount of spam that is coming in to our server. My issue is that it is also blocking local SMTP requests as well.

 

We have a program that runs on WS 2012 R2 with Remote Desktop Services. This program accesses a SQL database from a separate WS 2012 R2 running SQL 2012. When a user attempts to send an email from our program, the request is sent from the SQL server to our Exchange server (WS 2012 R2 running Exchange 2013 SP1). I have a receive connector enabled on the Exchange server for this relay. It is setup for TLS with permissions for anonymous users (settings required for SMTP from our aforementioned program), it will only receive mail from the SQL server, and it is only bound to the IPv4 address of the Exchange server through port 25.

 

The setup for the relay is correct and works great when greylisting is disabled. That being said, is there a way to configure ESET Mail Security to allow this relay while having greylisting enabled?

Link to comment
Share on other sites

  • 3 weeks later...

Hello Steven Theck,

 

Please configure the sending server’s IP address in the Exchange Allow List. For directions on this process, please see the appropriate TechNet articles below:

After configuring the Allow List, please ensure Mail Security is configured to exclude the addresses on the Exchange Allow List from Antispam scanning. Please follow the steps below for this process:

  1. Open EMSX main program window.
  2. Press the F5 key to enter the Advanced Setup tree.
  3. Navigate to Server protection -> Antispam protection -> Microsoft Exchange Server -> Transport Agent.
  4. In the Transport Agent window, enable the setting "Use Exchange Server whitelists to automatically bypass antispam protection".
  5. Click OK to close the Setup window.
  6. Press the F5 key to enter the Advanced Setup tree.
  7. Navigate to Server protection -> Antispam protection -> Antispam engine and click "Reload of antispam engine parameters".
  8. Click OK to close the Setup window.

After configuring both of these settings, all emails from the specified server should bypass Greylisting and all other Antispam scanning.

 

Thank you,
ChadH

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...