Jump to content

Recommended Posts

How would I go about adding a firewall rule for a PPTP VPN please? I know where the screen is but whenver I add the settings in it still fails to connect.

 

I went to the Zone and Rule setup screen and clicked on New. I then added the port for VPN connections 1723. But I don't know what it understands by local and remote ports.

 

I added:

  • Remote port: 1723
  • Local port: 1723
  • Direction: Both
  • Action: Allow
  • Profile: For every

The VPN has no special software, it just uses a standard windows vpn connection. I know that the VPN is running okay because when I turn off the firewall it connects fine. When it fails I get error 806.

 

My PC uses:

  • ESS 7.0.317.4
  • Windows 7 Pro Build 7601 6.1 SP1 x64 (fully up to date, Eset tray icon shows an "e")
Link to post
Share on other sites

The local port is going to be the port for the connection coming from the router to your workstation.

Remote port will be what the vpn connects to the router on.

 

This is how i have understood from the basic network topology of a VPN connection.

Link to post
Share on other sites

Hello,

 

Usually this can be accomplished by switching the firewall mode to learning which will allow it to create the necessary ports on its own, vs manually creating.

Or Interactive mode and standby for prompts to allow the rules to be made.

Link to post
Share on other sites

I don't know what permissions you don't have but you can simply upload pictures.

 

And you can also restore your previously written content, because the editor has an auto-save-function. For more information see my screenshots.

post-3952-0-04699500-1404916609_thumb.png

post-3952-0-20910500-1404916613_thumb.png

Edited by rugk
Link to post
Share on other sites

Yes you can only restore it if you not already clicked on "Post". Then the auto-save is deleted.

Sorry for this, but I hope not so much content got lost.

Link to post
Share on other sites

I always copy the text before I click the post button just in case something would go wrong. That way I have it saved and I can just paste it and try to post again.

Link to post
Share on other sites

The problem may simply be that the GRE packets are not getting through.

To resolve this issue, make sure the network router/firewall permits GRE protocol 47 (You will want to find and enable a "PPTP passthrough" feature on your router that knows how to handle the GRE packets). In fact both port 1723 and GRE protocol shoyld be opened/enabled to establish VPN connectivity by using PPTP.

Hope it could solve the problem.

Link to post
Share on other sites
  • 1 year later...

Why don´t you try a commercial VPN, these services make that kind of configurations for you. Try this site: Anonymweb.co.uk. It has very good reviews of VPN services.

Link to post
Share on other sites
  • 1 month later...

 

The problem may simply be that the GRE packets are not getting through.

To resolve this issue, make sure the network router/firewall permits GRE protocol 47 (You will want to find and enable a "PPTP passthrough" feature on your router that knows how to handle the GRE packets). In fact both port 1723 and GRE protocol shoyld be opened/enabled to establish VPN connectivity by using PPTP.

Hope it could solve the problem.

 

 

Coming back to this post again as I'm determined to figure this out. The VPN is consistently blocked by Eset.

 

I've determined that the HIPS is what is blocking the VPN as disabling it resolved the problem.

PPTP pass through is enabled on the router.

 

Would it be possible for you to give me some in / out rules to enable the VPN? They use a randomly generated IP address. I know the difference between TCP/UDP but knowing what should be able to go out / come in is tricky. I tried to do it myself but my rules end up being too general in nature and I risk lowering security.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...