Jump to content

Command line options for epi_win_live_installer.exe? (especially silent)


Recommended Posts

I'm evaluating ESET PROTECT Cloud.  We do not have Active Directory.  I am attempting to deploy silently to a few test machines. I have tried the Deployment Tool and it has not worked on any computer I've tried.

I have epi_win_live_installer.exe on a public share and I have remote command prompt access to all machines.  Is there a command line option to execute it silently?

Link to comment
Share on other sites

I got the deployment tool to work on a couple machines, but I never actually see the agent running on the client and they never show up in the cloud portal.  I even ran one again. It says "Success" and the only thing I can do is click Finish.  But there is no ESET process running and it's not in the portal.

image.png.b06e075c9185ac96f7441fbd8f664156.png

Link to comment
Share on other sites

If you got it to work on a couple of machines, you did better than I did. Even though it said success on every computer I ran it on, it didn't work. I finally gave up and I'm about to embark on a migration from my local setup to the cloud as shown here https://help.eset.com/protect_cloud/en-US/cloud_migration.html

Link to comment
Share on other sites

4 minutes ago, LesRMed said:

 Even though it said success on every computer I ran it on, it didn't work.

Guess you didn't read my entire post, this is exactly what happened!

Link to comment
Share on other sites

22 minutes ago, FusionScott said:

Guess you didn't read my entire post, this is exactly what happened!

I did, that's why I said if you got it to work on a couple of them, then you did better than I did. LOL

Link to comment
Share on other sites

When I said "work" I just meant it said "success".  The first few machines I tried it on didn't get that far.  It didn't actually install the agent on anything.

But I digress.

 

The deployment tool would be nice if it worked, but what I REALLY want is command line options so I can run it from anything I want (batch/powershell, JumpCloud, etc)

Link to comment
Share on other sites

On 1/27/2021 at 8:11 PM, FusionScott said:

When I said "work" I just meant it said "success".  The first few machines I tried it on didn't get that far.  It didn't actually install the agent on anything.

From my experience this happens if the push of the installer is successful but the machine is unable to download the agent afterwards.

In this case you can create a offline cache file:

Quote

If you do not want the installer to download the security product and the agent each time it runs, you can create an Offline Cache for the installer which it will use instead of download. To do so, on the first screen, navigate to the upper right corner and click the gear_icon gear icon. Click Download to download the ESETOfflinePackage.dat file. Keep in mind that the .dat file must be in the same folder as the installer .exe file in order to work. The next time the installer is executed it will use the .dat file instead of the online repository. This scenario is recommended for situations when the installer is executed on each new computer from a shared disk.

https://help.eset.com/epi/2/en-US/eca_win.html

 

For instructions on silent install please refer to the knowledge base article:
https://support.eset.com/en/kb6820-deploy-the-eset-management-agent-and-the-eset-endpoint-product-together-7x#Silent_Install

Link to comment
Share on other sites

Same issue here. We actually want to deploy the live installer from Intune as the idea is that the machines will be automatically configured when they connect to the internet. The switches don't seem to work on the live installer that comes with Cloud protect, and there doesn't seem to be a list of all of the switches (I've tried the old /? /help and --help but to no avail. 

We're moving client devices off the On Prem AD and keeping that for the server infrastructure and all Windows 10 Clients will be in AAD, with InTune (or Endpoint as its now called). This carry on of using file shares and GPO's to deploy software is from the '90s. 

The command we're trying to run is:-  epi_win_live_installer.exe --silent --accepteula --avr-disable

Link to comment
Share on other sites

I should add that running the command manually epi_win_live_installer.exe --silent --accepteula --avr-disable from the command line on the machine, with admin rights also does.... you've guessed it... nothing (or its doing it very slowly in the background, I've waited an hour). So clearly the switches for the on prem ESMC don't work with cloud protect. Frustrating would be one word for it.

Link to comment
Share on other sites

Hi All,

Its working from InTune *Endpoint using the command above. This is for the Live installer downloaded from our ESET Cloud Protect portal. Obviously you'll need to convert the .exe into a .intunewin file first, but it is now working and deploying without issue.

Quote

epi_win_live_installer.exe --silent --accepteula --avr-disable

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...