Jump to content

Product is installed but it is not running - Ubuntu 20.04 lts


Recommended Posts

Hello all, first off Eset Customer Support is trash.

I have paid a lot of money for Eset Protect cloud, and I have been sending support requests in only to never get answers back,  is this company still operating?
 

Ok now on to my problem...

Ubuntu 20.04 , "Product is installed but it is not running" on my Protect Cloud panel. I have 5 workstations that give this error. Can't seem to get any support form Eset or find much via google.

Anyone else come up with this issue?

The client install the Linux agent just fine and it reports in. But when the client install Endpoint 7.1.8.0 for Linux it seems to install without error but my control panel shows. Product is installed but it is not running

I did however read that we should remove secure boot from BIOS of the computer, I have not told the users to try it yet, but i am using a VM in virtualbox for troubleshooting, and I have the same issue and no secure boot is enabled.

On user's  side it does not really show any errors, its hard for me to troubleshoot them as everyone is remote, and the users are not very good at Linux... so I installed  Ubuntu 20.04.LTS in virtualbox for testing

 

So Eset seem like its running....

root@ubunu2004:/home/rob/Desktop# ps -ax |grep eset
    787 ?        Ssl    0:02 /opt/eset/RemoteAdministrator/Agent/ERAAgent --daemon --pidfile /var/run/eraagent.pid
   1365 ?        Ss     0:00 /opt/eset/eea/sbin/startd
   1367 ?        S      0:00 /opt/eset/eea/lib/logd
   1368 ?        S      0:00 /opt/eset/eea/lib/sysinfod
   1369 ?        Sl     0:01 /opt/eset/eea/lib/updated
   1370 ?        S      0:00 /opt/eset/eea/lib/licensed
   1371 ?        Sl     0:00 /opt/eset/eea/lib/confd
   1376 ?        Sl     0:00 /opt/eset/eea/lib/oaeventd
   1380 ?        Sl     0:09 /opt/eset/eea/lib/scand
   2013 tty2     Sl+    0:00 /usr/lib/xorg/Xorg vt2 -displayfd 3 -auth /run/user/1001/gdm/Xauthority -background none -noreset -keeptty -verbose 3
   2455 ?        S      0:00 /bin/sh /opt/eset/eea/lib/install_scripts/egui_autorestart.sh --gapplication-service
   2503 ?        Sl     0:00 /opt/eset/eea/lib/egui --gapplication-service
   2508 ?        S      0:00 /opt/eset/eea/lib/utild
   2641 pts/0    S+     0:00 grep --color=auto eset

/var/log/syslog has this in it...

an 14 12:59:39 ubunu2004 systemd[1]: Starting ESET Endpoint Antivirus...
Jan 14 12:59:39 ubunu2004 systemd[1]: Starting ESET Management Agent...
Jan 14 12:59:42 ubunu2004 systemd[1]: Started ESET Management Agent.
Jan 14 13:00:06 ubunu2004 check_start.sh[1362]: /var/opt/eset/eea/eventd/eset_rtp/ertp_excludes.c: In function ‘ertp_proc_excluded’:
Jan 14 13:00:06 ubunu2004 check_start.sh[1362]: /var/opt/eset/eea/eventd/eset_rtp/ertp_excludes.c:202:17: error: ‘struct mm_struct’ has no member named ‘mmap_sem’; did you mean ‘mmap_base’?
Jan 14 13:00:06 ubunu2004 check_start.sh[1362]: /var/opt/eset/eea/eventd/eset_rtp/ertp_excludes.c:207:15: error: ‘struct mm_struct’ has no member named ‘mmap_sem’; did you mean ‘mmap_base’?
Jan 14 13:00:06 ubunu2004 check_start.sh[1255]: make[3]: *** [scripts/Makefile.build:290: /var/opt/eset/eea/eventd/eset_rtp/ertp_excludes.o] Error 1
Jan 14 13:00:06 ubunu2004 check_start.sh[1254]: make[2]: *** [scripts/Makefile.build:519: /var/opt/eset/eea/eventd/eset_rtp] Error 2
Jan 14 13:00:06 ubunu2004 check_start.sh[788]: make[1]: *** [Makefile:1780: /var/opt/eset/eea/eventd] Error 2
Jan 14 13:00:06 ubunu2004 eea[1364]: ESET Endpoint Antivirus error: Error compiling on-access kernel modules
Jan 14 13:00:07 ubunu2004 oaeventd[1376]: ESET Endpoint Antivirus Error: Cannot open file /lib/modules/5.8.0-36-generic/eset/eea/eset_rtp.ko: No such file or directory#012
Jan 14 13:00:07 ubunu2004 oaeventd[1376]: ESET Endpoint Antivirus Error: Initialization of system handler for on-access scan has failed. Please update your OS and restart your computer, then check system logs.#012
Jan 14 13:00:08 ubunu2004 systemd[1]: Started ESET Endpoint Antivirus.
Jan 14 13:01:20 ubunu2004 /usr/lib/gdm3/gdm-x-session[2013]: (==) Matched modesetting as autoconfigured driver 1
Jan 14 13:01:20 ubunu2004 /usr/lib/gdm3/gdm-x-session[2013]: (II) LoadModule: "modesetting"
Jan 14 13:01:20 ubunu2004 /usr/lib/gdm3/gdm-x-session[2013]: (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
Jan 14 13:01:20 ubunu2004 /usr/lib/gdm3/gdm-x-session[2013]: (II) Module modesetting: vendor="X.Org Foundation"
Jan 14 13:01:20 ubunu2004 /usr/lib/gdm3/gdm-x-session[2013]: (II) modesetting: Driver for Modesetting Kernel Drivers: kms
Jan 14 13:01:20 ubunu2004 /usr/lib/gdm3/gdm-x-session[2013]: (WW) Falling back to old probe method for modesetting
Jan 14 13:01:20 ubunu2004 /usr/lib/gdm3/gdm-x-session[2013]: (II) UnloadModule: "modesetting"
Jan 14 13:01:20 ubunu2004 /usr/lib/gdm3/gdm-x-session[2013]: (II) Unloading modesetting
Jan 14 13:01:23 ubunu2004 licensed[1370]: ESET Endpoint Antivirus Error: Cannot receive data from server: Network is unreachable#012
Jan 14 13:01:23 ubunu2004 licensed[1370]: message repeated 2 times: [ ESET Endpoint Antivirus Error: Cannot receive data from server: Network is unreachable#012]
Jan 14 13:01:26 ubunu2004 dbus-daemon[1930]: [session uid=1001 pid=1930] Activating service name='eset.eea' requested by ':1.33' (uid=1001 pid=2195 comm="/usr/libexec/gnome-session-binary --systemd-servic" label="unconfined")
Jan 14 13:01:28 ubunu2004 dbus-daemon[1930]: [session uid=1001 pid=1930] Successfully activated service 'eset.eea'

Any ideas?

Thanks..

 

 

Link to post
Share on other sites
  • Administrators

Please provide me with your ticket ID so that I can check the status of it. This forum is meant for sharing knowledge with users and cases that need further troubleshooting require a support ticket to be created. Forums in general do not provide ticket tracking functionality to ensure that you receive a timely response.

Link to post
Share on other sites

The last case i received an email about is :
Case #485500

The one before that was,
Case #484068

I filled out the online form twice before the above mentioned Cases, only to not receive any emails at all. I attached logs to these forms I filled out, so not sure where all that ended up.

I only came to these forms because Customer support is too slow...

When I pay for a product as much as I did for Eset, I expect 24 hours is max time for support response. not 72 hours.

As mentioned before logs are attached to previous post.

Please advise

Link to post
Share on other sites
  • Administrators

I've inquired our Linux expert about this issue. The conclusion is that recent changes in kernel 5.8 require update of Endpoint. We're working on Endpoint v7.1.9.0 which should be ready in a few days and will be fully compatible with kernel 5.8.

Regarding the tickets you've mentioned, they were created just yesterday at 10:02 and 10:57 according to the information from our colleagues in the US.

Int. ref: P_EESU-716

Link to post
Share on other sites

Thanks for the update, but i have made at least 4 requests since Monday... I will give your "US Colleagues" the benefit of the doubt this time.

I look forward to the files.... was there a post put up regarding this incompatibility with kernel 5.8?

Have a great and safe day!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...