Jump to content

Question | Automate failed client task to rerun again until successfully deployed.


Recommended Posts

Hi all, 
I ran into the issue where sometimes an automated task failed due to a reason of "Time out" or "package not found in repository"  for installing AV software. using a dynamic group and a task assigned to that group. 

Any chance to automate the "run on failed" until EEA\EES is installed successfully and the agent clears that "dynamic auto-deploy folder" 

Attaching screenshot of the failed attempt. 
You can see it says the task is still "Planned" to run, but it never actually run again - is that a bug? 


Thanks!

failed task.jpg

Link to post
Share on other sites
  • Administrators

First of all, in this case the task will never succeed due to the reason - "package not found in repository". Create a new install task, select an existing package from the repository and send the task to desired clients.

Link to post
Share on other sites
16 hours ago, Marcos said:

First of all, in this case the task will never succeed due to the reason - "package not found in repository". Create a new install task, select an existing package from the repository and send the task to desired clients.

Hi Marcos, 
Perhaps I wasn't clear with my question. 
This task has ran and succeeded on quite a few jobs with the exact same AV installation. 
it gets a failed attempt once in a while (no idea why, the package is still the latest AV installation) and if i'll run the same client task again manually it'll work. it just needs a rerun. 

now that we've cleared that, any way to get that to work? 

Also I mentioned another status of "TImed out" 

 

Thanks

Link to post
Share on other sites
  • ESET Staff

Any chance firewall is used that might block access of AGENT to ESET repository servers and thus failing, depending on where AGENT is downloading package from? Various data-centers and public CND providers are used to server installers, so missing access to one of them could result in seemingly random failures.

Link to post
Share on other sites
1 hour ago, MartinK said:

Any chance firewall is used that might block access of AGENT to ESET repository servers and thus failing, depending on where AGENT is downloading package from? Various data-centers and public CND providers are used to server installers, so missing access to one of them could result in seemingly random failures.

I never tried to mess around with that, so I assume unless ESET has some default to block certain repos, there shouldn't be anything blocking it. 

in terms of working through proxy, I have such solution deployed, but I'm limiting it to agent reporting only and not mirroring or serving as download points for app

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...