Jump to content

Product is Installed But Not Running - ESET File Security

Recommended Posts

Eset File Security:  v7.2.574.0

Eset Agent Version:  v8.0.2216.0

Ubuntu: v20.04.01 LTS

Environment:  Virtual Server configured for vSphere 6.7


My organization needs to get this one figured out.  This error seems to be a recurring theme for your products in the Linux environment, as I've read countless posts with similar issues.  Most seem to be closed out with no solutions documented in the threads.  Our company is starting to deploy a lot more Ubuntu servers in our environment and need to have this addressed. 

During troubleshooting I've tried both the libssl-dev version 1.0.2, and the newer 1.1 that comes with 20.04.  I can't find a definitive answer on which one to use, however I think that is less of a problem because both don't seem to work.

I've tried uninstalling and re-installing Efs, via agent and the installer I downloaded from your site, to no avail.  The error messages that are in the screenshot I've posted recur in the syslog every few minutes.

I can't even get a license status when running the request (in case registration was the issue).

I've been looking at similar statuses as the image below shows for all our Linux servers for over a year now in our console.  Each release of the software seems to break even more functions for Linux ESET File Security.


Is this an issue with ESET File Security for Linux Servers?  Should I use another product that ESET is recommends for Enterprise environments?

Thanks in advance for your attention to, and help with this matter.

-- Robert

Link to comment
Share on other sites

  • ESET Staff

Hi Robert,

sorry to hear, that you have difficulties with our product. From yours screenshot I can see that our services couldn't start correctly. Could be caused by issues during installation or something is preventing them to run correctly. 

EFS has its own log collecting script (/opt/eset/efs/sbin/collect_logs.sh), could you please execute it and attach output?  Archive you have attached in previous comment is produced by script designed for older versions of linux products. 

Could it be possible to generate strace of our service? it could help us identify what going on there.


strace -ffo /tmp/strace_efs -s 256 /opt/eset/efs/sbin/startd

Before executing this command, please stop our service "systemctl stop efs" and make sure that none of efs service is left there ("ps -ef | grep efs" output should not contain any service running, if something  is still running, kill it). After executing strace command, it should generate "strace_efs*" files in /tmp folder, please attach them. 

Are you using some other security tools on this machine for hardening? or something else that could interfere with our product? 

You mentioned that you tried also installation from package, during this process didn't you spot any errors/warning?  Something like folder couldn't be created or similar (could be that some error occurred, but installation continued further). 



Edited by kurco
Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...