Jump to content

Problem with old ESET Remote Administration


mgfeal
 Share

Go to solution Solved by MartinK,

Recommended Posts

Hi,

We have a problem with our old ESET Remote Administration Server (appliance). When we try to login, we have this error:

Login failed: Connection has failed with state 'Not connected'

 

If we check /var/log/eset/RemoteAdministrator/Server/trace.log we can find these messages:

Error: CDatabaseModule [Thread 7fd5c0fc1700]: Probing database connection failed. Next connection attempt will be in 10 seconds. 10 more attempts will be made. The database access layer reported: [unixODBC][Driver Manager]Data source name not found, and no default driver specified (0)

 

/etc/opt/eset/RemoteAdministrator/Server/StartupConfiguration.ini

DatabaseType=MySqlOdbc
DatabaseConnectionString=Driver=MySQL ODBC 5.3 Unicode Driver;Server=127.0.0.1;Port=3306;User=era;Password={ovhgUJ54};CharSet=utf8;NO_LOCALE=1;Database=era_db;

 

/etc/odbcinst.ini

[PostgreSQL]
Description             = ODBC for PostgreSQL
Driver          = /usr/lib/psqlodbc.so
Setup           = /usr/lib/libodbcpsqlS.so
Driver64                = /usr/lib64/psqlodbc.so
Setup64         = /usr/lib64/libodbcpsqlS.so
FileUsage               = 1
UsageCount              = 2

[MySQL ODBC 8.0 Unicode Driver]
Driver          = /usr/lib64/libmyodbc8w.so
UsageCount              = 2

[MySQL ODBC 8.0 ANSI Driver]
Driver          = /usr/lib64/libmyodbc8a.so
UsageCount              = 2

 

This server has an old ESET version, but we need to access to it to migrate our agents and recover policies and more.

We review this article: https://support.eset.com/en/kb6760-cannot-connect-to-the-web-console-after-linux-mysql-update-eset-remote-administrator-6x

But it doesn't work.

Our mysql-connector-odbc version is mysql-connector-odbc-8.0.21-1.el6.x86_64

MySQL version: mysql  Ver 14.14 Distrib 5.6.49, for Linux (x86_64)

CentOS version is CentOS release 6.10 (Final)

 

Does anyone know how we can fix it?

Thank you very much!

Link to comment
Share on other sites

  • ESET Staff
  • Solution

Seems that upgrade of ODBC driver was performed, and the one used by ESMC is no longer available. In this case there are technically two possibilities:

  • Change name of the driver in StartupConfiguration.ini  to match current state, i.e. use:
    Driver=MySQL ODBC 5.3 Unicode Driver;
  • Re-install original MySQL ODBC 5.3 driver.

Preferred solution is second one, as there are known issues with 8.0 ODBC driver, so it is not guaranteed it will work correctly and also it is not officially supported - except some specific versions of this driver which do work correctly (more details in documentation).
If possible, I would recommend to upgrade/migrate appliance to new version - as you have experienced issues that were targeted long time ago, you appliance is probably old (version 6.5?)

Link to comment
Share on other sites

We changed StartupConfiguration.ini with

Driver=MySQL ODBC 8.0 Unicode Driver;

And now it works perfect!!

Many thanks!

Yes, it's and old server, but we need to redirect agents to the new one and copy all policies.

Link to comment
Share on other sites

  • ESET Staff
1 hour ago, mgfeal said:

Yes, it's and old server, but we need to redirect agents to the new one and copy all policies.

Just to let you know, but there is an upgrade mechanisms that will migrate whole database to new appliance (https://help.eset.com/esmc_deploy_va/72/en-US/?va_upgrade_migrate.html) in which case all data, including policies will be retained. In case of deployment of this new server on the same IP address/hostname, also client's connectivity should work without any issues.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...