Jump to content

Database server connection is not working


Go to solution Solved by Mauricio Osorio,

Recommended Posts

Hello guys,
I have tried to configure ESMC with a Mysql database in a Windows environment, but even though I have correctly configured mysql 8.0 parameters it does not work. It shows me this error during installation:

image.png.2b53b04e5efedbbcfe9a4a2e60ab1044.png

You can see the my.ini file in the attachment.

I followed the instructions in this KB: https://help.eset.com/esmc_install/72/es-CL/mysql_windows.html#mysql_config.

These are the installed MySQL components:

image.png.ff5ac82a24c8419c697a36f788848c79.png

Thanks for your help.

Regards.

 

my.rar

Link to post
Share on other sites
  • Administrators

Please provide also an install log created after running the server msi installer with the "/lvx* install.log" parameter.

Link to post
Share on other sites
  • Solution

Hello guys,
I think I found the problem and it really is not technical, the problem is with the translation into Spanish from Latin America. Let me show you:

In the latin american user guide, you can see this instructions:

image.png.75d302541a854374a21b84a1b6e311a9.png

Highlighted in yellow you can see that it indicates that for Linux MySQL version 8, the parameter log_bin_trust_function_creators = 1 must be added or modified. But it is indicated only for Linux environments. In the English manual this option is not conditioned to Linux:

image.png.8871c7a9835f3d060c551936a852bce4.png

As I was working in a Windows environment, I chose not to make this modification, because the manual indicated that it should only be done in a Linux environment. Just to discard I decided to make the change and everything works correctly.

Thank you very much for your collaboration and if you can please change the manual (Latin America Spanish) in this section as it may cause confusion.

Regards.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...