Jump to content

Problem to change the ERE/ESMC administrator password

Recommended Posts

Hi everyone,

I have to change the Native Administrator password of ESMC installation. When I logging into Webmin (root) and I go through the appropriate menu to change the pass or add my new CA, I see this error:

Output from command ..

stty: standard input: Inappropriate ioctl for device

ESET Security Management Center Server Installer (version: 7.1.503.0), Copyright © 1992-2019 ESET, spol. s r.o. - All rights reserved.

Extracting archive, please wait...
Archive extracted to /tmp/tmp.3ha91q9Z8w.
Checking OpenSSL ... done [OpenSSL 1.0.2k-fips 26 Jan 2017]
Reading previous installation settings ... done
Checking installed version... done
Status of current installation is: REPAIR
Checking database connection ... failure

Error: An error occurred while trying to connect to the database. Error code: (2002). Unable to continue.


I attached all the info of my installation.

Please help me.


Screenshot 2020-08-24 at 10.52.17.png

Screenshot 2020-08-24 at 15.53.08.png

Screenshot 2020-08-24 at 15.54.53.png

Link to comment
Share on other sites

  • ESET Staff

Seems that problem is that ESMC is configured to connect to database with hostnane "localhost" which causes problem as in this case, ODBC driver is actually trying to use local file sockets instead of TCP connection. Could you please provide more details of environment used? Is it ESMC Appliance? And if so, what was the initial version that was deployed?

To confirm, I would recommend to manually modify file:


so that it contains: Server= instead of Server=localhost.

In case system has enabled SELinux protection, it might be required to run also command:

/sbin/restorecon -F -R -v /etc/opt/eset/RemoteAdministrator/Server

to correct configuration after manuall changes.

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...