Jump to content

Connected Home Monitor Issues


Recommended Posts

It's been a long while since I've posted to this forum (last time was 2014), as I've not really had many issues, however, I am having one now, so here I am.

So, the Connected Home Monitor is sort of cool, but it has been around now for several releases, and I still see some quirks with it--and this time, I am finding I cannot do something, specific and it is annoying the out of me.

What started this was the procurement of a new router.  I upgraded from a Netgear WNDR4500 to a Nighthawk AC2300 (which appears as R7000P in the Monitor).  And my first attempt at the cut-over did not go as well as expected (i.e., it flat-out failed, and it was my fault), and I didn't have the time to futz with it, so I re-cabled my old router for the evening.

The next night, however, I successfully swapped out the routers.  Yea!

However, when I ran the Connected Home Monitor, I was dismayed to see multiple R7000P entries, as well as the old WNDR4500 entry.  Worse, I cannot get rid of the bogus, phantom R700P entries to correct the (Sonar) "field". In other words, selecting some of the R7000P entries just causes the page to blink, as opposed to being taken to the details frame.  All of the other objects can be selected (but only when in the Sonar view) and get necessary details.  Selecting the List view allows no further drill down or actions.  And I consider that to be a problem.  I should be able to do stuff in List view.  Why else have it?

Additionally, I also had a beef with the Editable name fields in the Details view for the longest time, too, because I stupidly was clicking on the little pencil "icon", which isn't a functional region to select.  I accidentally discovered the text next to the pencil was, indeed, editable, so I finally was able to name some of the objects to something more meaningful to me.  I just didn't know the name itself was the editable field.  The reason for this is simple:  Many applications provide a pencil icon to indicate something's editable, but in all cases, you actually click that icon (or so-equipped button) to make a change.  So conditioned was I (I think they call it web style standards), that for the longest time I managed not to place my mouse over the actual object name and "discover" that's how you actually edit the object name.  I guess I was dense....  And while I am no less dense, now, it would still behoove ESET to adhere to some semblance of web page design standards, here.

As annoying as not being able to perform editing or deleting (or really perform any action while in List View), the bigger problem is why can't I remove the bogus phantom objects (all of which are "routers")?  Especially when I only have one router in the network.  And why does one of the bogus R7000P objects show up in List View as being affiliated with Xerox as a vendor?  I have zero Xerox products in my possession, so this object is wrong for multiple reasons.

And I want the field to reflect reality, and no amount of re-scanning is changing this.

So, I set about trying to figure out where the objects are stored, as I reasoned, perhaps, I can move/rename the file that houses the objects, perform a new scan and force ESET to generate a completely new result, and maybe, just maybe, the bogus objects would be gone.

I went sleuthing and found, under ProgramData, the following files that are most probably Connected Home Monitor-related:

  • homenet.dat
  • homenet_cloud_cache.dat
  • homenethash.dat

Of course, these files are not in any sort of human-readable format, but homenet.dat looks like the main object I might have wanted to hide so as to force a clean, (and actual) result set.

It would be nice if the files were xml as opposed to dat, and even though xml files aren't all that pretty to look at, either, they're easier than what I see inside of the dat files....

When I tried to move/rename these files, I was prevented from doing so, of course, as ESET was protecting them; I tried to temporarily shutdown ESET via msconfig so that it wouldn't start at boot, and then I would probably be able to do something with the 3 files above, but, again, ESET was preventing that action, also.  Don't get me wrong, I am not bemoaning that aspect, as I recognize preventing ESET from running would be a pretty sizable vulnerability....

What I want to do--and what should be readily available to the user, is the means of being able to wipe the field slick and let the Connected Monitor Scan "re-discover" from scratch, the actual, available network devices.  In the absence of that ability, I would like to know how I can achieve what I want by temporary manipulation of ESET.

I believe several improvements with this Tool are warranted, but for now, I'd settle for simply being able to wipe out what is currently presented and let a new result be generated.  Hoping someone can tell me how best to accomplish.

Best Regards,

Mike Gentry 

Connected Home Monitor List View.jpg

Link to comment
Share on other sites

  • Administrators

Please delete "C:\ProgramData\ESET\ESET Security\homenet.dat"  in safe mode. Should there be any further issues, I'd recommend contacting your local ESET support and create a ticket so that the case is properly tracked.

Link to comment
Share on other sites

Thanks, Marcos....  Looks like I need to contact support and raise a ticket.  Removing the file as you suggested while in Safe Mode, wiped the field slick, alright, BUT, now the "Scan Your Network" button is greyed out, now, so the ability to generate a new scan result appears to be non-existent.

Link to comment
Share on other sites

Well--I think I fixed it.  It wasn't just having to get rid of the homenet.dat file--it was also getting rid of the other 2 (basically the same 3 files I identified in the original post).  Doing that cleared the field AND allowed a new network scan to be conducted.  And doing that gave me objects that reflect reality.

So, in summary, all 3 homenet-related files need to be removed or renamed while in Safe Mode.

Thanks for the assistance.

Regards,

Mike Gentry

Edited by megentry1
Changed Mod to Mode
Link to comment
Share on other sites

  • Administrators
12 hours ago, megentry1 said:

now the "Scan Your Network" button is greyed out, now, so the ability to generate a new scan result appears to be non-existent.

This would happen when the network was marked as public. Only private networks can be scanned.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...