Jump to content

New Smart Security Works Too Well


Go to solution Solved by megentry1,

Recommended Posts

Long time user of ESET, but am a bit aggravated at the moment....

 

There are several matters contained within this post--I've detailed them and summarized them at the end....

 

I installed the latest version of Smart Security.

 

Beyond the usual problem of having to use the Eset Uninstaller (in safe mode), and the fact one is told you can install safely over top here in the forum (right within the thread that announces the new version), but on the download page it is RECOMMENDED you uninstall first....  For me, the last several years, it's not a matter of "recommendation"--I have to do it.  Some file under the "Charon" directory always prevents me installing over top.  I find I MUST remove Smart Security first....  It wasn't always like this, but has been for several years, now--at least for me.  But, I digress....

 

The latest version installed just fine.  No problems there.  I ran for hours, but it got late, so I shutdown my system.

 

In fact, no problems were observed at all, that is, until the first time turning the computer back on after securing it the night before....

 

My first indication of problems were my WeatherBug and Secunia PSI Internet connections were failing....  I then launched my browser( s ).  Same thing.  Basically, anything that required an Internet connection was failing.

 

I tried temporarily turning off Protection and the Firewall.  This did not change the status quo.

 

So, I uninstalled ESET Smart Security, and instantly, I had connectivity again (no protection, now), but connectivity.

 

I went through Registry and manually removed any remaining ESET entries, rebooted again, and then re-installed ESET (I had downloaded the offline installer, so that's how I re-installed it).

 

Once again, ESET installed just fine, everything seemed fine.

 

Until I powered off and powered back on later on in the day....

 

Once again, no Internet connectivity.  Smart Security works "too well".

 

Once again, I had to uninstall it.

 

So, it seems something about the latest version of ESET and my system do not like one another.

 

I wanted to go back to the previous version,  but this is where things get really aggravating (almost as bad as not being able to copy & paste inside this narrative)....

 

I navigated my way to hxxp://kb.eset.com/esetkb/index?page=content&id=SOLN2885 as this page supposedly provides previous versions of your product.

 

ONLY, IT DOESN'T....

 

The version that was downloaded (which is also aggravating as the filename doesn't possess the version number, and msi cannot be run as administrator like exe files can) is the same NEW version of your product.

 

Of course, I don't know this until I start that install process and Eset takes stock of my system, and finally displays the version number in the lower left portion of the installer dialog box.

 

Even though I selected the Windows 7, 32-bit version from the KB page dealing with "How do I download and install older versions of ESET products", the version presented and downloaded is still the newest version:  7.0.317.4--NOT THE PREVIOUS VERSION

 

Unfortunately, I no longer have my former version's offline installer.

 

The problems I am reporting are many and varied (the main ones are bolded):

 

To summarize:

 

1.  Latest version allows zero Internet traffic, but only AFTER rebooting following an install

2.  The fact I have to resort to uninstalling your product using an ESET uninstaller expressly built for the purpose in Safe Mode continues to be an onerous issue--one I reported years ago, but have gotten no relief.  I have lived with it, but because I am here again reporting a more serious problem, decided I'd let this one bubble to the top and mention it yet again.

3.  Cannot seemingly use copy and paste within the narrative box when writing something on this forum

4.  ESET's use of msi files rather than exe (exe's can be run as administrator; msi files cannot), AND the lack of embedding version info in the filename so it is obvious at a glance makes for not knowing what you've downloaded until after you try to install.

5.  Your KB page devoted to providing previous versions of ESET products, DOESN'T

6.  I have a paid license for a product that is not working, and no way to get back an older version that was working....

 

 

Link to comment
Share on other sites

  • ESET Moderators

Hello Megentry1,

 

can you please contact customer care with the networking issue?

 

Which version of the product would you like to use?

I checked the KB article and I was able to download older version of the product.

Link to comment
Share on other sites

Peter,

 

Thanks for responding.

 

I do have an open case with Customer Care, but as of this writing, they're not responding.  I raised the case Friday evening, and spoke First Tier support, but was told it was too near closing time to resolve with Second Tier--and I had to wait until Tuesday due to the holiday weekend.  So waited I have....

 

On Tuesday, I began "camping" by my telephone waiting for the promised Customer Care return call starting at 7PM Local (Eastern) (the agreed upon time 7:30 local--4:30 Pacific)), only to receive an email message at 7:31 PM (local) from Customer Care stating "they tried to reach me, but could not"....  Odd.  I was right next to the phone and it never rang.  I am now on hold trying to get through, but am up against the clock again, as their work day will be ending soon....

 

Congrats on getting to download an older version, but the link on that knowledgebase article to download older ESET Smart Security for (Windows 7 32-bit) only downloaded the latest version....  For me, anyhow.

 

I did find an offline installer version elsewhere on ESET, but it wasn't the previous v7.xxx version, but in fact, was a 6.xxx version--and, unfortunately, this exhibited the same problem the latest version did.  I should have just left well-enough alone and kept my previous v7 installed instead of moving to the latest version, as now I have an issue I can't seem to resolve on my own.  I've never encountered this kind of problem before....

 

And getting hold of someone at Customer Care is trying my patience.  It looks like I am going to have to miss work tomorrow morning in order to schedule another appointment.  This assumes I can even get hold of someone to set another appointment.

 

Not very happy in Virginia right now.

 

Mike Gentry

Link to comment
Share on other sites

//Update

 

The previous evening's missed appointment seemed to have stemmed from First Tier support entering my phone number into the appointment system incorrectly--resulting in last night's missed window.  However, this evening I was finally able to connect with George L. from Customer Care.  He witnessed first-hand the problem I reported, and he captured some data via SysInternal's Procmon application, but his work day concluded before we could ftp the results for further analysis.  I have something going on Thursday, so we're getting back together on Friday to upload the captured information.  Hard to tell how long the resulting analysis will take, but it's definitely an odd problem.  After re-installing 7.0.317.4, and then rebooting, that's when the issue manifests.  Until the reboot occurs, everything is fine.  We've ruled out the Windows firewall remaining engaged.  Also, we found we can ping an IP or Domain successfully, but all other Internet connectivity is essentially blocked until I uninstall ESS (again).  Hopefully, Procmon will reveal what is causing this issue.

 

Searching the forum leading up to this evening's session, revealed a similar problem back in 2008 under the former forum.  In that case, another customer had the same sort of issue (i.e., no connectivity after reboot following installation of Eset).  That person's problem was slightly different from mine in that he also was running a product called "Hide My IP".  By contrast, I'm NOT running that product or anything remotely similar.  That thread is found here:  hxxp://www.wilderssecurity.com/threads/eset-smart-security-and-hide-my-ip.220741/    Unfortunately, I did not see a "resolution" specified in that particular thread.  Since it involved an application I am not using, even if a solution had been determined, such might not have any bearing in my case.

 

Just wanted to provide an update.  BTW, for the record, George was very friendly and helpful.  Am hopeful a resolution will be forthcoming.

 

Will continue to provide status as it evolves--for posterity--just in case anyone else should encounter something similar (although, hopefully, this particular problem (whatever it is) is rare).

 

Regards,

 

Mike Gentry

Link to comment
Share on other sites

//Update

 

Connected with George L. w/ESET Customer Care, 5/30 Friday evening.  We tried several actions to no avail, but did capture some more logs (PCAP as well as the previous evening's Procmon logs)--all of which were ftp'd back to Eset (for eventual transfer to Home Office).  Heard from George again, today, Monday 6/2, with something else he wanted me to try in the meantime--namely, re-enabling the Eset fw driver (it's currently disabled so only Antivirus protection is running).  One of his colleagues suggested I try running the firewall in Learning mode, so I re-enabled the driver, and rebooted.  Learning Mode created a slew of new rules, but once it settled down, I still had no Internet connectivity.  I've communicated this back to George via separate correspondence associated with the actual trouble ticket.

 

I reverted back to disabled driver operation.

 

George also mentioned, perhaps, the next thing to try is disabling all of the non-Microsoft elements in msconfig, and start the process of enabling items one-by-one until I find the "winner".  At least, I think I interpreted his intent correctly....  Such an evolution will require several hours of uninterrupted activity and I'm not certain when I'll manage to get to that.  In the meantime, we're awaiting analysis by the Third Level folks.  Maybe they'll see something interesting before I am able to attempt hours of selective enabling.

 

Just wanted to provide "status" as this continues to evolve.

 

Regards,

 

Mike Gentry

Link to comment
Share on other sites

//Update

 

Many log files and various attempts have been analyzed and suggested--without finding a specific cause of the problem.  Customer Care floated the notion perhaps I should consider operating without the firewall and just continue using AV.

 

Not wanting it to come to that, and not accepting that as the final answer, I did some more poking around on the Internet.  In so doing, I stumbled across an older Wilder's Security forum item which sounded a lot like my problem....

 

In the old case (see hxxp://www/wildersecurity.com/threads/lost-access-to-home-network-after-installing-eset-smart-security.269608/ ), someone's suggestion was to add  192.168.0.0/255.255.255.0 (presumably their own subnet) to the Trusted Zone.  This looked like something I could check, and so I did.  Interestingly enough, my subnet existed with the DnsIp...DhcpIp information, BUT was conspicuously absent from the Trusted Zone.

 

So I added it (although I decided to narrow the scope a bit....  I added 192.168.1.0/255.255.255.0, instead).

 

Instantaneously, my Internet connection was restored.  I could use browsers; various applications that required connectivity all sprang to life, etc.

 

And better still, this behavior persisted following subsequent reboots.

 

While I don't know whether my private home subnet should have been automatically added to the Trusted Zone during installation, the fact remains, this was not happening, and was the cause of my problems.

 

I have relayed all of this to Customer Care and I hope to ascertain whether this should have been automatic behavior during installation, and if so, what could have impeded such from occurring.

 

If nothing else, perhaps this thread can serve to help someone else out should they encounter the loss of Internet connectivity following installation of Eset Smart Security....  

 

Simply stated, check to see whether your network appears in the Trusted Zone.

 

For now, my ticket is still open as Customer Care is closed.  I won't hear anything more from them until next week.

 

Best Regards,

 

Mike Gentry  

Link to comment
Share on other sites

  • 2 weeks later...
  • Solution

//Final Update

 

Customer Care wound up having a few other clients with the same reported problem.  One thing in common was we all had Realtek as our NIC provider.  And Customer Care tried to solve the problem by having those clients add their respective subnets to the Trusted Zone--just as I had done, but, unfortunately, their problem was not solved.

 

Don't know if this is noteworthy or not, but Realtek did release two NIC drivers very close to one another in early June (which is uncharacteristic for them in terms of release cycle--usually they may go several months between releases).  Don't know if this is a coincidence or not.  Just throwing it out there for consideration.

 

If I feel particularly adventurous, now that I have updated NIC drivers yet again, it would be nice to see what happens if I (temporarily) remove my subnet from the Trusted Zone--to see if the symptom comes back, -OR- if normal behavior is maintained without having my subnet listed.

 

Presumably, the issue must be something else, as I systematically removed all of my Realtek drivers I've installed over the years--removing the software as I marched backward until all my system could find was the Microsoft driver.  There was no change in symptom until I added my subnet to the Trusted Zone.  I simply don't know what it is about my machine that suddenly seems to require this.

 

As my problem was 'solved' by adding my subnet to the Trusted Zone, Customer Care rather unceremoniously closed my ticket.  Even so, George L. from Customer Care was great to work with....

 

We may never know what the real culprit was, but I guess am going to mark this thread as Solved, (even though we never really found the smoking gun).

 

Regards,

 

Mike Gentry

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...