Jump to content

Can't get web control to function


Recommended Posts

Hi there

 

I have a group of machines with End Point Security 5 installed and would like to use the Web control but I can't get it to function, either through remote administrator or applying the settings directly on a machine.  What I have found so far using facebook as a test and modifying the setup on an individual machine is:

 

1. I CAN get it to work if I block facebook under Web Access Protection/URL address management but...

 

2. I CAN'T get it to work if I block facebook using a rule in Web control/Configure rules

 

I can confirm that I have the following set:

 

Web access protection/Enable HTPP protocol checking is set and ports are 80,8080 and 3128

HTTPS filtering mode is 'Use HTTPS protocol checking' on port 443

Web Control/Integrate into System = Set

Personal Firewall/Sytem Integration = All features active

 

On the eSet opening screen I see Web Control = Enabled

 

In the blocking rule I have tried both whole categories and individual websites both for 'Any user or group' and also for a specific named user, in both cases neither has any effect

 

Does anyone have any clues as to what I can look at next?  I would prefer to use Web Control to block whole categories rather than having to specify individual URLs

 

Thanks for that

 

Richard

Edited by richardpepp
Link to comment
Share on other sites

ok.  I'm not sure why that will work but I'm very happy to give it a try.  I'll get back later once I've had a chance to test it out

 

Hi,

Because thats how controlling the web works.

Your computer always queries a dns server when you request a website to go to.

If you query ESET's dns, they will turn you around if you have an ip in your do not allow list.

Link to comment
Share on other sites

Ah, are you saying that for category filtering to work we have to be using ESET's DNS?  At the moment we are using the DNS server on our Windows server

 

For Marcos: Changing the DNS to the Google one (8.8.8.8) makes no difference - category filtering still doesn't work

 

I was under the  impression that the filtering was done at a per machine level but maybe that's the difference between WebContol and URL filtering

 

thanks again

Edited by richardpepp
Link to comment
Share on other sites

Eset installs a driver that run directs traffic through a dns server. (AFAIK). Where the driver can contain your block list maybe. This is proprietary information and i am speculating. Just hoping to help you undertand. :)

 

Your DNS settings in your adapter should remain automatic, your router, or what your ISP has instructed, or Google dns, or Open dns, etc etc.

 

I suspect Marcos is having you change dns on your side to rule out issues by process of elimination, only in an attempt to help resolve your issue of course.

Edited by Arakasi
Link to comment
Share on other sites

  • Administrators

The problem is that some routers do not handle TXT DNS queries / responses properly, however, in such case using Google's DNS servers should solve the issue. I'd suggest contacting Customer care and providing them with a Wireshark pcap log from the moment when Web control doesn't work.

Link to comment
Share on other sites

Thanks all for your answers.  This makes good sense so I'll try again with a few different machines both in and outside our network to see if I can narrow it down.  If i can't sort it i'll get on to customer care with the Wireshark log.  If I do sort it I'll post it back here

 

Best wishes all

 

Richard

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...