Jump to content
offbyone

Trigger on static group

Recommended Posts

Hi.

We created a trigger on a static group, which should be fired whenever a computer joins this group (for the first time).

However what is strange is, that when displaying the trigger properties the target type is displayed as "Dynamic Group".

Any idea what could be wrong?

sc.png.0942db74bdfe9d25c51bc1d10a0043e5.png

Share this post


Link to post
Share on other sites

Here the behaviour is absolutely reproducible.

Does anybody know if this is only a cosmetic problem?

Share this post


Link to post
Share on other sites

Hello,

In this case, if you want to have the task executed only "first time" upon entering the group, you should not use the "joined dynamic group trigger" (there is no such trigger available for static group). Instead you should set a trigger "ASAP" and make sure there is no expiration set, as past the expiration date, the trigger will stop working: 

I would however recommend you to create a dynamic group, focusing on a computer problem "product not activated", eventually together with a condition for a specific software installed (EEA / EES / ...). By that, even if any issues with activation appear, such trigger would "fix it". Alternatively, you can have the same task triggered on "joined DG" and then "scheduled repeatedly", with for example once a day, so it will retry the reactivation later again. 

Hope that this helps. 

PS: Are you sure, that the "Approved" is indeed a static group? As That´s not possible to be checked from the screenshot you provided. 

Share this post


Link to post
Share on other sites

Hi MichalJ.

Thanks for you answer.

The group indeed is a static group and that's the reason I asked.

SC.PNG.797118c3e56fd31f23c868b714fb97e0.PNG

We extensively use dynamic groups as this is a really great feature of ESET, and "Approved" is the only static group we use. Our intention is to not activate the product automatically but only after someone checked what device it is and then moved it to the "Approved" group.

The trigger description generated make us think that it will work as intended.

SC.PNG.fd36b0d9098bdd6e62462405293884c2.PNG

However whenever we create a trigger on that group the TARGET TYPE is shown as "Dynamic Group". We checked multiple times with same result.

Share this post


Link to post
Share on other sites

I have been able to reproduce the behavior. It seems to me as a bug, so I will report it to our QA / DEV teams. that a confusing description is displayed for the group, as indeed it shows "dynamic group" even when "static group" is set as target. 

It only shows like that when you try to "edit trigger". 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...