Jump to content

Recommended Posts

Hi Guys with Due respect to all the IT guy's here I need help I am not able to share a folder over my home network . using TP link Router. Trying to share folder from my Desktop connected on LAN Cable.  trying to get the data on my Laptop connected on wifi on both the systems im using ESET internet security.

Humble request as I have seen old posts try to figure out the same steps but no luck at all maybe a magical spell from someone might help me out.

Link to post
Share on other sites
  • Administrators

Did you mark your network as home network upon detection on both machines? If so, then sharing between the machines would be enabled since both would be within the trusted zone. You can also try temporarily pausing the firewall to rule it out as the cause of issues while trying to set up shares.

Link to post
Share on other sites

Hi Marcos Thank you for your precious time and reply. Yes I did home network on both from the firewall known network rules and still cant detect both systems on each other,  Really will appreciate your guidance to proceed. I also do not not want to pause or stop my firewall.  Please guide what will happen if i Pause my firewall will I be able to detect both the systems on each other ??

please Guide as i want the sharing to be permanently on forever.

Link to post
Share on other sites

Hello Itman thank you for sparing time and helping me out. What I meant to say was. My desktop is connected with Ethernet cable and my laptop is on wifi. Both systems are connected on same network using TP Link router. But unable to share files both ways. Unable to detect both the PC's. I use Eset Internet Security on both Desktop and Laptop.

Your guidance will be of utmost help.

Link to post
Share on other sites

Is Eset installed on both the laptop and desktop?

Scratch this - you answered in your previous reply.

Edited by itman
Link to post
Share on other sites

Following this guide: https://pureinfotech.com/setup-network-file-sharing-windows-10/ and ensure file sharing is properly set up for the desktop.

Eset firewall rules only apply to the actually network connections used in file sharing activities. Eset doesn't actually set internal Windows permissions in regards to file sharing.

Link to post
Share on other sites

Hi i Just wanted to confirm if i pause the firewall will I be able to setup the sharing smoothly. and after i Remove the Pause stage of the firewall and bring back to normal will the file sharing remain active as it was during the pause state. Will the firewall interfere again.

Link to post
Share on other sites

For both the laptop and desktop, do the following.

Open Eset GUI. Then select, Tools -> Connected Home Monitor.

For the laptop is the IP address for the desktop shown on the Connected Home Monitor display?

Likewise, for the desktop is the IP address for the laptop shown on the Connected Home Monitor display?

Link to post
Share on other sites

Yes I am able to see IP address on both the systems from Connected Home Monitor display.
However wanted to share one more thing in the Networks section when i click and page opens i can see both systems in Media devices on both the pc's when i open them windows media player opens up.  however still cant see the shared folder from desktop on my laptop.

 

Kindly guide

Link to post
Share on other sites

Yes followed the procedure as it was mentioned in the link but still the folder does not show up on the network.

kindly help me out I really appreciate your efforts and taking time out. My wife is a Teacher and she needs to keep sharing data but its very tedious doing it manually all the time.

Please let me know if any screen shots required for more understanding.

Link to post
Share on other sites

Eset assumes NetBIOS ports are being used for file sharing.

On both the laptop and desktop, open a command prompt window and enter the following command:

ipconfig /all

Verify that NetBIOS is enabled on both devices:

Eset5_NetBIOS.png.67de38219c7a408518f140300e3324ae.png

 

Link to post
Share on other sites

On both PCs, open Win Explorer and mouse click on the Network setting. Does that populate with network devices?

Link to post
Share on other sites
  • Administrators

You could check https://www.windowscentral.com/how-share-files-and-printers-without-homegroup-windows-10  and temporarily pause ESET firewall on both machines to rule out the possibility that the communication is blocked by incorrect firewall configuration, especially with regard to the trusted zone.

Link to post
Share on other sites

Hey Guys thank you finally Luckily though not able to detect my Desktop on my Laptop
but the folder i shared from the Desktop using the link which generates after sharing it worked and I was able to see the folder shared.
need one more help . I am trying to share an entire Drive from my laptop and when the link gets generated im not able to open that on my desktop it gives me this error 


image.png.2d055b6a8e8edc82a0d102a5ac5ddb0d.png

Please guide.

Link to post
Share on other sites
Posted (edited)

To share a drive on the laptop, follow this guide: https://quehow.com/how-to-share-an-entire-drive-in-windows-10/4406.html . The procedure is similar to sharing a folder.

Note: on my Win 10 1909 build, I do not have the "Share with" option but rather "Give access to" option. Possible due to the fact, I don't have file sharing enabled on my PC.

Also one reply to this article stated it doesn't work. If that's the case for you, then follow this guide: https://www.tomshardware.com/news/how-to-share-drives-windows-pc,36936.html . In this case, you are creating a mapped network drive. Also take note of this:

Quote

There is one thing to note before we get started: The methods described in this article require that the Windows account on the computer that your shared drive is physically attached to must be both an admin account and password protected. If your account is not password protected, you will still receive prompts to enter a password when connecting to the drive over the network. Because you cannot enter a blank password, you will be effectively gated from connecting to the drive. Sharing a drive without password protection is possible, but it can be finicky. The easiest method is to have a password on the account of the computer hosting the shared drive.

I interpret the above to be that the default Win 10 limited admin account satisfies the admin account requirement but can't 100% vouch for this.

Edited by itman
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...